summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-06 21:33:36 +0200
committerMartchus2016-06-06 21:33:36 +0200
commita3ca34df1e057dc5e5ec206d35fae2183443d134 (patch)
tree6de6156298683861dbf26b3d3e3b46c5260642a6
downloadaur-a3ca34df1e057dc5e5ec206d35fae2183443d134.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd83f958731b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jun 6 19:33:29 UTC 2016
+pkgbase = mingw-w64-libfilezilla
+ pkgdesc = Library used by FileZilla (mingw-w64)
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://filezilla-project.org/
+ arch = any
+ license = GPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://downloads.sourceforge.net/project/filezilla/libfilezilla/0.5.2/libfilezilla-0.5.2.tar.bz2
+ md5sums = be50726969cabda0f1b1c9ee432c1f4e
+
+pkgname = mingw-w64-libfilezilla
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65fb22540608
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+_name=libfilezilla
+pkgname=mingw-w64-libfilezilla
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Library used by FileZilla (mingw-w64)"
+arch=('any')
+url="https://filezilla-project.org/"
+license=('GPL')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-configure')
+options=(staticlibs !strip !buildflags)
+install=
+source=("http://downloads.sourceforge.net/project/filezilla/libfilezilla/${pkgver}/${_name}-${pkgver}.tar.bz2")
+md5sums=('be50726969cabda0f1b1c9ee432c1f4e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ autoreconf -i
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}" && cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ ${_arch}-configure
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ done
+}