summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2024-03-31 01:24:50 +0100
committerjakob2024-03-31 01:24:50 +0100
commit53467625c281413fa74ed8d2b4412d3415a62391 (patch)
treedcd810aaca5adb249a08a82474b88116674973f2
parent86ce925799efee220ac7575936d7745179309e81 (diff)
downloadaur-53467625c281413fa74ed8d2b4412d3415a62391.tar.gz
Don't build tests & Update CMake flag names
`BUILD_CLAR` was renamed to `BUILD_TESTS`. `THREADSAFE` was renamed to `USE_THREADS`. `STDCALL` was removed. Build with SSH support as the non-mingw package does. Use `cmake -B` & `cmake --build` as the non-mingw package does.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ee9d2a4607d..cd527f3969a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
pkgver = 1.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libgit2/libgit2
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 0a97d306f369..24655d6a18e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libgit2
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
depends=(mingw-w64-{crt,curl,libssh2,openssl,zlib})
@@ -19,14 +19,12 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libgit2-${pkgver}"
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
- -DTHREADSAFE=ON \
- -DBUILD_CLAR=OFF \
- -DSTDCALL=ON \
- ..
- make
- popd
+ -DUSE_THREADS=ON \
+ -DBUILD_TESTS=OFF \
+ -DUSE_SSH=ON \
+ -B build-${_arch}
+ cmake --build build-${_arch} --verbose
done
}