summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2021-09-28 13:55:27 +0200
committerjakob2021-09-28 13:55:27 +0200
commit6e05fcf7f3df45c479da87e9155cb75d9e4f8c5c (patch)
treecb4695d8535ee2bc836679ec0485411679f91208
parent208193ca9a634556d3f6c6bb67514167d1646b1a (diff)
downloadaur-6e05fcf7f3df45c479da87e9155cb75d9e4f8c5c.tar.gz
1.2.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71cc20fe48bd..6596a9eab200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 1.1.1
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
@@ -14,7 +14,7 @@ pkgbase = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v1.1.1.tar.gz
- sha256sums = 13a525373f64c711a00a058514d890d1512080265f98e0935ab279393f21a620
+ source = https://github.com/libgit2/libgit2/archive/v1.2.0.tar.gz
+ sha256sums = 701a5086a968a46f25e631941b99fc23e4755ca2c56f59371ce1d94b9a0cc643
pkgname = mingw-w64-libgit2
diff --git a/PKGBUILD b/PKGBUILD
index fbd644063e98..73c2d0a8a3fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=1.1.1
+pkgver=1.2.0
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
@@ -11,7 +11,7 @@ options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
-sha256sums=('13a525373f64c711a00a058514d890d1512080265f98e0935ab279393f21a620')
+sha256sums=('701a5086a968a46f25e631941b99fc23e4755ca2c56f59371ce1d94b9a0cc643')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -19,7 +19,11 @@ build() {
cd "${srcdir}/libgit2-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..
+ ${_arch}-cmake \
+ -DTHREADSAFE=ON \
+ -DBUILD_CLAR=OFF \
+ -DSTDCALL=ON \
+ ..
make
popd
done
@@ -32,5 +36,7 @@ package() {
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
- install -D -m644 "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -D -m644 \
+ "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}