summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2018-09-10 10:53:03 +0200
committerjakob2018-09-10 10:53:53 +0200
commit7a18904f9d90c4eb3a3dba414e6cfc2b23b6caf1 (patch)
treefec8e1067caf75f233bc02166e407c45a93c266d
parent3d548cf8336bb6e2b706aa9e770bf3b0e15f2cb8 (diff)
downloadaur-7a18904f9d90c4eb3a3dba414e6cfc2b23b6caf1.tar.gz
0.27.4 & dependencies
Add libssh2, curl, openssl & zlib deps. Thanks @adsun.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 911bc4c6e402..bafe7c42b330 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 0.27.3
+ pkgver = 0.27.4
pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
license = GPL
makedepends = mingw-w64-cmake
depends = mingw-w64-crt
+ depends = mingw-w64-curl
+ depends = mingw-w64-libssh2
+ depends = mingw-w64-openssl
+ depends = mingw-w64-zlib
provides = mingw-w64-libgit2
conflicts = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v0.27.3.tar.gz
- sha1sums = 0ba7125c547b6538eae7f5117e8d39d9f2a8d5f2
+ source = https://github.com/libgit2/libgit2/archive/v0.27.4.tar.gz
+ sha1sums = 47392972e2c9689dbce0cf68b1e678fcc9915c2a
pkgname = mingw-w64-libgit2
diff --git a/PKGBUILD b/PKGBUILD
index 5ca620a4247e..c44b1e6fdd4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=0.27.3
+pkgver=0.27.4
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
-depends=(mingw-w64-crt)
+depends=(mingw-w64-{crt,curl,libssh2,openssl,zlib})
makedepends=(mingw-w64-cmake)
conflicts=(mingw-w64-libgit2)
provides=(mingw-w64-libgit2)
@@ -13,7 +13,7 @@ options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
-sha1sums=('0ba7125c547b6538eae7f5117e8d39d9f2a8d5f2')
+sha1sums=('47392972e2c9689dbce0cf68b1e678fcc9915c2a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -22,8 +22,8 @@ build() {
# unset LDFLAGS
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DTHREADSAFE=ON -DCMAKE_BUILD_TYPE=Release -DBUILD_CLAR=OFF -DSTDCALL=ON ..
- ${_arch}-cmake -DTHREADSAFE=ON -DCMAKE_BUILD_TYPE=Release -DBUILD_CLAR=OFF -DSTDCALL=ON --build .
+ ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..
+ ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON --build .
popd
done
}