summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2022-09-22 17:47:20 +0200
committerjakob2022-09-22 17:49:06 +0200
commit92d7c5faafcfdf8feeedc7012947ecab5abd54b2 (patch)
treed132237a37d8a342afb90b3e9e0a50b8bc7c9bc3
parent5f1ec2b3dcb2ffea53510fcfed0ee86bb361c7d0 (diff)
downloadaur-92d7c5faafcfdf8feeedc7012947ecab5abd54b2.tar.gz
1.5.0
Add patch for the faulty uppercase windows.h include, which is already reported and fixed upstream for the next release.
-rw-r--r--.SRCINFO8
-rw-r--r--0001-fix-uppercase-windows-h-include.patch25
-rw-r--r--PKGBUILD13
3 files changed, 40 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7496c2b12d59..523306333477 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 1.4.4
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
@@ -14,7 +14,9 @@ pkgbase = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v1.4.4.tar.gz
- sha256sums = e9923e9916a32f54c661d55d79c28fa304cb23617639e68bff9f94d3e18f2d4b
+ source = https://github.com/libgit2/libgit2/archive/v1.5.0.tar.gz
+ source = 0001-fix-uppercase-windows-h-include.patch
+ sha256sums = 8de872a0f201b33d9522b817c92e14edb4efad18dae95cf156cf240b2efff93e
+ sha256sums = a7a87b9467ef4f0a4e2f68f75c4b3e30c6b681773c636192726e59500538cf7d
pkgname = mingw-w64-libgit2
diff --git a/0001-fix-uppercase-windows-h-include.patch b/0001-fix-uppercase-windows-h-include.patch
new file mode 100644
index 000000000000..b61b102766eb
--- /dev/null
+++ b/0001-fix-uppercase-windows-h-include.patch
@@ -0,0 +1,25 @@
+From d64f3d0992ec278d843c397b4b52e3434962c197 Mon Sep 17 00:00:00 2001
+From: Vinz2008 <68145293+Vinz2008@users.noreply.github.com>
+Date: Thu, 11 Aug 2022 00:25:31 +0200
+Subject: [PATCH] Fix #6365
+
+---
+ src/cli/opt.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cli/opt.c b/src/cli/opt.c
+index 72df5877f..62a3430d1 100644
+--- a/src/cli/opt.c
++++ b/src/cli/opt.c
+@@ -23,7 +23,7 @@
+ #include "opt.h"
+
+ #ifdef _WIN32
+-# include <Windows.h>
++# include <windows.h>
+ #else
+ # include <fcntl.h>
+ # include <sys/ioctl.h>
+--
+2.37.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 656ee8208f86..89a533216baf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=1.4.4
+pkgver=1.5.0
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
@@ -10,13 +10,20 @@ makedepends=(mingw-w64-cmake)
options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
-source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
-sha256sums=('e9923e9916a32f54c661d55d79c28fa304cb23617639e68bff9f94d3e18f2d4b')
+source=(
+ "https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz"
+ "0001-fix-uppercase-windows-h-include.patch"
+)
+sha256sums=(
+ '8de872a0f201b33d9522b817c92e14edb4efad18dae95cf156cf240b2efff93e'
+ 'a7a87b9467ef4f0a4e2f68f75c4b3e30c6b681773c636192726e59500538cf7d'
+)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libgit2-${pkgver}"
+ patch -p1 < "$srcdir/0001-fix-uppercase-windows-h-include.patch"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \