summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2020-06-05 21:15:48 +0200
committerjakob2020-06-05 21:15:59 +0200
commitaa8b9338c39fdb941c0f816a7cb5c834c6b4996a (patch)
tree854458179112f370c388acdf30372e4af50b9953
parent68df0916cfe908e5e31dca13ffd56bc9e37d5ddc (diff)
downloadaur-aa8b9338c39fdb941c0f816a7cb5c834c6b4996a.tar.gz
Remove conflicts/provides & gcc-libs makedepends
Replace cmake build call by make. Thanks to Xantares for the hints.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fecaf249fecb..058c42dacecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
pkgver = 1.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libgit2/libgit2
arch = any
license = GPL
makedepends = mingw-w64-cmake
- makedepends = gcc-libs
depends = mingw-w64-crt
depends = mingw-w64-curl
depends = mingw-w64-libssh2
depends = mingw-w64-openssl
depends = mingw-w64-zlib
- provides = mingw-w64-libgit2
- conflicts = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index 635828e29481..aa3ed99316c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,11 @@
pkgname=mingw-w64-libgit2
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
depends=(mingw-w64-{crt,curl,libssh2,openssl,zlib})
-makedepends=(mingw-w64-cmake gcc-libs)
-conflicts=(mingw-w64-libgit2)
-provides=(mingw-w64-libgit2)
+makedepends=(mingw-w64-cmake)
options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
@@ -23,7 +21,7 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..
- ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON --build .
+ make
popd
done
}