summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2023-04-18 17:27:21 +0200
committerjakob2023-04-18 17:27:21 +0200
commitbc98b2b608bbc527d6652f554550ca50a6d1e5aa (patch)
treeec023bd7450210ce2be8a2f85e327abfcdcb8b18
parent03d761225dbd6d0eed8cea12954929ce19741178 (diff)
downloadaur-bc98b2b608bbc527d6652f554550ca50a6d1e5aa.tar.gz
1.6.4
-rw-r--r--.SRCINFO8
-rw-r--r--0001-fix-uppercase-windows-h-include.patch25
-rw-r--r--PKGBUILD9
3 files changed, 6 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0824bf6ffe06..8eed7fc1fadd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 1.5.1
+ pkgver = 1.6.4
pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
@@ -14,9 +14,7 @@ pkgbase = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v1.5.1.tar.gz
- source = 0001-fix-uppercase-windows-h-include.patch
- sha256sums = 7074f1e2697992b82402501182db254fe62d64877b12f6e4c64656516f4cde88
- sha256sums = a7a87b9467ef4f0a4e2f68f75c4b3e30c6b681773c636192726e59500538cf7d
+ source = https://github.com/libgit2/libgit2/archive/v1.6.4.tar.gz
+ sha256sums = d25866a4ee275a64f65be2d9a663680a5cf1ed87b7ee4c534997562c828e500d
pkgname = mingw-w64-libgit2
diff --git a/0001-fix-uppercase-windows-h-include.patch b/0001-fix-uppercase-windows-h-include.patch
deleted file mode 100644
index b61b102766eb..000000000000
--- a/0001-fix-uppercase-windows-h-include.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From d64f3d0992ec278d843c397b4b52e3434962c197 Mon Sep 17 00:00:00 2001
-From: Vinz2008 <68145293+Vinz2008@users.noreply.github.com>
-Date: Thu, 11 Aug 2022 00:25:31 +0200
-Subject: [PATCH] Fix #6365
-
----
- src/cli/opt.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/cli/opt.c b/src/cli/opt.c
-index 72df5877f..62a3430d1 100644
---- a/src/cli/opt.c
-+++ b/src/cli/opt.c
-@@ -23,7 +23,7 @@
- #include "opt.h"
-
- #ifdef _WIN32
--# include <Windows.h>
-+# include <windows.h>
- #else
- # include <fcntl.h>
- # include <sys/ioctl.h>
---
-2.37.3
-
diff --git a/PKGBUILD b/PKGBUILD
index ade217237b8e..44d9df67d807 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=1.5.1
+pkgver=1.6.4
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
@@ -10,17 +10,14 @@ makedepends=(mingw-w64-cmake)
options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
-source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz"
- "0001-fix-uppercase-windows-h-include.patch")
-sha256sums=('7074f1e2697992b82402501182db254fe62d64877b12f6e4c64656516f4cde88'
- 'a7a87b9467ef4f0a4e2f68f75c4b3e30c6b681773c636192726e59500538cf7d')
+source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
+sha256sums=('d25866a4ee275a64f65be2d9a663680a5cf1ed87b7ee4c534997562c828e500d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libgit2-${pkgver}"
- patch -p1 < "$srcdir/0001-fix-uppercase-windows-h-include.patch"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \