summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob2019-09-03 12:17:29 +0200
committerJakob2019-09-03 12:17:29 +0200
commitd6683b9d6b04a1d0dda687e7033b62d5396a5a08 (patch)
tree9d534cf5c2243bd6d3806115c0ac5e8ca0c11275
parentce19bf2c97db1bffd52379bea3d0ddf113824834 (diff)
downloadaur-d6683b9d6b04a1d0dda687e7033b62d5396a5a08.tar.gz
0.28.3 with temporary fix for src/path.c
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD47
-rw-r--r--aclapi-include-case.patch13
3 files changed, 46 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9942b13a109c..7a9c4c11039d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 0.28.2
+ pkgver = 0.28.3
pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
@@ -17,8 +17,10 @@ pkgbase = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v0.28.2.tar.gz
- sha256sums = 42b5f1e9b9159d66d86fff0394215c5733b6ef8f9b9d054cdd8c73ad47177fc3
+ source = https://github.com/libgit2/libgit2/archive/v0.28.3.tar.gz
+ source = aclapi-include-case.patch
+ sha256sums = ee5344730fe11ce7c86646e19c2d257757be293f5a567548d398fb3af8b8e53b
+ sha256sums = e9dcef212732027605e8720e76c6f9fa731a528f131feaa86a137c56e906ea25
pkgname = mingw-w64-libgit2
diff --git a/PKGBUILD b/PKGBUILD
index 14682e29da28..373a85344b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=0.28.2
+pkgver=0.28.3
pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
@@ -12,28 +12,37 @@ provides=(mingw-w64-libgit2)
options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
-source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
-sha256sums=('42b5f1e9b9159d66d86fff0394215c5733b6ef8f9b9d054cdd8c73ad47177fc3')
-
+source=(
+ "https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz"
+ aclapi-include-case.patch
+)
+sha256sums=(
+ 'ee5344730fe11ce7c86646e19c2d257757be293f5a567548d398fb3af8b8e53b'
+ 'e9dcef212732027605e8720e76c6f9fa731a528f131feaa86a137c56e906ea25'
+)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/libgit2-${pkgver}"
- # unset LDFLAGS
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..
- ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON --build .
- popd
- done
+ cd "${srcdir}/libgit2-${pkgver}"
+
+ patch -Rsfp1 --dry-run < "$srcdir/aclapi-include-case.patch" \
+ || patch -p1 < "$srcdir/aclapi-include-case.patch"
+
+ # unset LDFLAGS
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..
+ ${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON --build .
+ popd
+ done
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/libgit2-${pkgver}/build-${_arch}"
- make DESTDIR="${pkgdir}" install
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- done
- install -D -m644 "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libgit2-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ done
+ install -D -m644 "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/aclapi-include-case.patch b/aclapi-include-case.patch
new file mode 100644
index 000000000000..9449ccbb58dd
--- /dev/null
+++ b/aclapi-include-case.patch
@@ -0,0 +1,13 @@
+diff --git a/src/path.c b/src/path.c
+index 90473fc..34346a8 100644
+--- a/src/path.c
++++ b/src/path.c
+@@ -14,7 +14,7 @@
+ #include "win32/w32_buffer.h"
+ #include "win32/w32_util.h"
+ #include "win32/version.h"
+-#include <AclAPI.h>
++#include <aclapi.h>
+ #else
+ #include <dirent.h>
+ #endif