summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjakob2020-11-02 12:26:02 +0100
committerjakob2020-11-02 12:26:02 +0100
commitee8f544eb383f662777403240c0a9baceeccbd59 (patch)
tree1f6ae26bd2adff4ec1407551bef67bae30212115
parentaa8b9338c39fdb941c0f816a7cb5c834c6b4996a (diff)
downloadaur-ee8f544eb383f662777403240c0a9baceeccbd59.tar.gz
1.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 058c42dacecc..6b1cfe174ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libgit2
pkgdesc = A portable, pure C implementation of the Git core methods (mingw-w64)
- pkgver = 1.0.1
- pkgrel = 2
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/libgit2/libgit2
arch = any
license = GPL
@@ -14,8 +14,8 @@ pkgbase = mingw-w64-libgit2
options = staticlibs
options = !buildflags
options = !strip
- source = https://github.com/libgit2/libgit2/archive/v1.0.1.tar.gz
- sha256sums = 1775427a6098f441ddbaa5bd4e9b8a043c7401e450ed761e69a415530fea81d2
+ source = https://github.com/libgit2/libgit2/archive/v1.1.0.tar.gz
+ sha256sums = 41a6d5d740fd608674c7db8685685f45535323e73e784062cf000a633d420d1e
pkgname = mingw-w64-libgit2
diff --git a/PKGBUILD b/PKGBUILD
index aa3ed99316c8..70ea3261d236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: jakob <grandchild@gmx.net>
pkgname=mingw-w64-libgit2
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.1.0
+pkgrel=1
pkgdesc="A portable, pure C implementation of the Git core methods (mingw-w64)"
arch=(any)
depends=(mingw-w64-{crt,curl,libssh2,openssl,zlib})
@@ -11,13 +11,12 @@ options=(staticlibs !buildflags !strip)
license=(GPL)
url="https://github.com/libgit2/libgit2"
source=("https://github.com/libgit2/libgit2/archive/v${pkgver}.tar.gz")
-sha256sums=('1775427a6098f441ddbaa5bd4e9b8a043c7401e450ed761e69a415530fea81d2')
+sha256sums=('41a6d5d740fd608674c7db8685685f45535323e73e784062cf000a633d420d1e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/libgit2-${pkgver}"
- # unset LDFLAGS
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DTHREADSAFE=ON -DBUILD_CLAR=OFF -DSTDCALL=ON ..