summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-11-29 18:13:22 -0500
committerAndrew Sun2019-11-29 18:13:22 -0500
commit19e2b72ffa72e89637cd793859b6f3680dcb302a (patch)
tree52b82105488769ff53d52cc0a9590b620baaf7a6
parentc0129418aa739864d14898a4b69cba1e934db799 (diff)
downloadaur-19e2b72ffa72e89637cd793859b6f3680dcb302a.tar.gz
fix build with gawk 5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--gawk5.diff128
3 files changed, 138 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb365daa1795..805e00d84efb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libgpg-error
pkgdesc = Support library for libgcrypt (mingw-w64)
pkgver = 1.36
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnupg.org
arch = any
license = LGPL
@@ -16,6 +16,7 @@ pkgbase = mingw-w64-libgpg-error
source = 02-fix-symbollist-on.mingw.patch
source = 05-w32-gen.all.patch
source = 07-windows-build.patch
+ source = gawk5.diff
validpgpkeys = D8692123C4065DEA5E0F3AB5249B39D24F25E3B6
validpgpkeys = 031EC2536E580D8EA286A9F22071B08A33BD3F06
sha256sums = babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c
@@ -24,6 +25,7 @@ pkgbase = mingw-w64-libgpg-error
sha256sums = 364da17febff3f6eeffee5a5f1e3ed1b644adeb5ca48a972c5c4675c10238a91
sha256sums = 9ccdc567810d58526888fd11c5f7d01101627011840b7b75a91e96aa9e71f49d
sha256sums = ff73e4bde792f5c84c99810b83467d20247856076a92e5940f9fd64a8815187d
+ sha256sums = b3f12474986a0fe7340013e3dbe963acf303d76f53c440ef38e8233f4cb7928f
pkgname = mingw-w64-libgpg-error
diff --git a/PKGBUILD b/PKGBUILD
index 412b018ee8c0..7618f2592df4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libgpg-error
pkgver=1.36
-pkgrel=1
+pkgrel=2
pkgdesc="Support library for libgcrypt (mingw-w64)"
arch=(any)
url="http://www.gnupg.org"
@@ -14,13 +14,15 @@ source=("ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${pkgver}.tar.bz2"
"01-mingw32-fix-potomo.mingw.patch"
"02-fix-symbollist-on.mingw.patch"
"05-w32-gen.all.patch"
- "07-windows-build.patch")
+ "07-windows-build.patch"
+ 'gawk5.diff')
sha256sums=('babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c'
'SKIP'
'252349e58d418adfec5621af1e09753db52b1bf39983aa3bc398d636afb9b495'
'364da17febff3f6eeffee5a5f1e3ed1b644adeb5ca48a972c5c4675c10238a91'
'9ccdc567810d58526888fd11c5f7d01101627011840b7b75a91e96aa9e71f49d'
- 'ff73e4bde792f5c84c99810b83467d20247856076a92e5940f9fd64a8815187d')
+ 'ff73e4bde792f5c84c99810b83467d20247856076a92e5940f9fd64a8815187d'
+ 'b3f12474986a0fe7340013e3dbe963acf303d76f53c440ef38e8233f4cb7928f')
validpgpkeys=('D8692123C4065DEA5E0F3AB5249B39D24F25E3B6' # Werner Koch
'031EC2536E580D8EA286A9F22071B08A33BD3F06') # NIIBE Yutaka (GnuPG Release Key) <gniibe@fsij.org>
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -31,6 +33,8 @@ prepare() {
patch -p1 -i ${srcdir}/02-fix-symbollist-on.mingw.patch
patch -p1 -i ${srcdir}/05-w32-gen.all.patch
patch -p1 -i ${srcdir}/07-windows-build.patch
+ # upstream fix to allow build with gawk 5.x
+ patch -Np1 -i ${srcdir}/gawk5.diff
autoreconf -fiv
}
diff --git a/gawk5.diff b/gawk5.diff
new file mode 100644
index 000000000000..c9149be10fe2
--- /dev/null
+++ b/gawk5.diff
@@ -0,0 +1,128 @@
+diff --git a/lang/cl/mkerrcodes.awk b/lang/cl/mkerrcodes.awk
+index ae29043..9a1fc18 100644
+--- a/lang/cl/mkerrcodes.awk
++++ b/lang/cl/mkerrcodes.awk
+@@ -122,7 +122,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/Makefile.am b/src/Makefile.am
+index ce1b882..f2590cb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -293,7 +293,7 @@ code-from-errno.h: mkerrcodes$(EXEEXT_FOR_BUILD) Makefile
+
+ errnos-sym.h: Makefile mkstrtable.awk errnos.in
+ $(AWK) -f $(srcdir)/mkstrtable.awk -v textidx=2 -v nogettext=1 \
+- -v prefix=GPG_ERR_ -v namespace=errnos_ \
++ -v prefix=GPG_ERR_ -v pkg_namespace=errnos_ \
+ $(srcdir)/errnos.in >$@
+
+
+diff --git a/src/mkerrcodes.awk b/src/mkerrcodes.awk
+index 46d436c..e9c857c 100644
+--- a/src/mkerrcodes.awk
++++ b/src/mkerrcodes.awk
+@@ -85,7 +85,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrcodes1.awk b/src/mkerrcodes1.awk
+index a771a73..4578e29 100644
+--- a/src/mkerrcodes1.awk
++++ b/src/mkerrcodes1.awk
+@@ -81,7 +81,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrcodes2.awk b/src/mkerrcodes2.awk
+index ea58503..188f7a4 100644
+--- a/src/mkerrcodes2.awk
++++ b/src/mkerrcodes2.awk
+@@ -91,7 +91,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkerrnos.awk b/src/mkerrnos.awk
+index f79df66..15b1aad 100644
+--- a/src/mkerrnos.awk
++++ b/src/mkerrnos.awk
+@@ -83,7 +83,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+diff --git a/src/mkstrtable.awk b/src/mkstrtable.awk
+index c9de9c1..285e45f 100644
+--- a/src/mkstrtable.awk
++++ b/src/mkstrtable.awk
+@@ -77,7 +77,7 @@
+ #
+ # The variable prefix can be used to prepend a string to each message.
+ #
+-# The variable namespace can be used to prepend a string to each
++# The variable pkg_namespace can be used to prepend a string to each
+ # variable and macro name.
+
+ BEGIN {
+@@ -102,7 +102,7 @@ header {
+ print "/* The purpose of this complex string table is to produce";
+ print " optimal code with a minimum of relocations. */";
+ print "";
+- print "static const char " namespace "msgstr[] = ";
++ print "static const char " pkg_namespace "msgstr[] = ";
+ header = 0;
+ }
+ else
+@@ -110,7 +110,7 @@ header {
+ }
+
+ !header {
+- sub (/\#.+/, "");
++ sub (/#.+/, "");
+ sub (/[ ]+$/, ""); # Strip trailing space and tab characters.
+
+ if (/^$/)
+@@ -150,7 +150,7 @@ END {
+ else
+ print " gettext_noop (\"" last_msgstr "\");";
+ print "";
+- print "static const int " namespace "msgidx[] =";
++ print "static const int " pkg_namespace "msgidx[] =";
+ print " {";
+ for (i = 0; i < coded_msgs; i++)
+ print " " pos[i] ",";
+@@ -158,7 +158,7 @@ END {
+ print " };";
+ print "";
+ print "static GPG_ERR_INLINE int";
+- print namespace "msgidxof (int code)";
++ print pkg_namespace "msgidxof (int code)";
+ print "{";
+ print " return (0 ? 0";
+
+