summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-08 18:25:44 -0700
committerSchala2015-06-08 18:25:44 -0700
commitafb265807d66a82aae0ca1f79aa007dd2c2f4f8c (patch)
tree813513757ea9e603253a19c9f16247f3fa7e5e4d
downloadaur-afb265807d66a82aae0ca1f79aa007dd2c2f4f8c.tar.gz
added patches from https://github.com/Alexpux/MINGW-packages/blob/master/mingw-w64-libgpg-error
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--02-fix-symbollist-on.mingw.patch10
-rw-r--r--05-w32-gen.all.patch11
-rw-r--r--07-windows-build.patch17
-rw-r--r--PKGBUILD52
6 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0fa76631d47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-libgpg-error
+ pkgdesc = Support library for libgcrypt (mingw-w64)
+ pkgver = 1.19
+ pkgrel = 2
+ url = http://www.gnupg.org
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-gettext
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.19.tar.bz2
+ source = ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-1.19.tar.bz2.sig
+ source = 02-fix-symbollist-on.mingw.patch
+ source = 05-w32-gen.all.patch
+ source = 07-windows-build.patch
+ sha1sums = 4997951ab058788de48b989013668eb3df1e6939
+ sha1sums = SKIP
+ sha1sums = a7bbc4637aba322cd43aa7c5a6d99faa8f801133
+ sha1sums = 07f1c34b3861bc2658d1cad4fafe895f654815df
+ sha1sums = 367b3b33da0ae3a8f959ae8535d6584a997ad6b8
+
+pkgname = mingw-w64-libgpg-error
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5012a3480bf6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.bz2
+*.sig
+*.xz
diff --git a/02-fix-symbollist-on.mingw.patch b/02-fix-symbollist-on.mingw.patch
new file mode 100644
index 000000000000..fdc3af7afd87
--- /dev/null
+++ b/02-fix-symbollist-on.mingw.patch
@@ -0,0 +1,10 @@
+--- libgpg-error-1.10/src/gpg-error.def.in.orig 2012-12-21 13:48:57 +0400
++++ libgpg-error-1.10/src/gpg-error.def.in 2012-12-21 15:37:31 +0400
+@@ -4,7 +4,6 @@
+
+ #include <config.h>
+
+-EXPORTS
+ gpg_strerror @1
+ gpg_strerror_r @2
+ gpg_strsource @3
diff --git a/05-w32-gen.all.patch b/05-w32-gen.all.patch
new file mode 100644
index 000000000000..65e690900f7e
--- /dev/null
+++ b/05-w32-gen.all.patch
@@ -0,0 +1,11 @@
+--- libgpg-error-1.13/src/Makefile.am.orig 2014-05-02 23:33:18.692420700 +0000
++++ libgpg-error-1.13/src/Makefile.am 2014-05-02 23:40:08.833001900 +0000
+@@ -119,6 +119,8 @@
+ libgpg_error_la_DEPENDENCIES = $(gpg_error_res) gpg-error.def
+ intllibs =
+
++CPPFLAGS += $(DEFS) $(DEFAULT_INCLUDES)
++
+ #
+ # }}} End Windows part
+ #
diff --git a/07-windows-build.patch b/07-windows-build.patch
new file mode 100644
index 000000000000..c50a3016224c
--- /dev/null
+++ b/07-windows-build.patch
@@ -0,0 +1,17 @@
+--- libgpg-error-1.16/src/Makefile.am.orig 2014-09-23 23:35:27.832600000 +0500
++++ libgpg-error-1.16/src/Makefile.am 2014-09-24 00:08:20.985200000 +0500
+@@ -268,9 +268,14 @@
+ pre_mkheader_cmds = :
+ parts_of_gpg_error_h += ./lock-obj-pub.native.h
+
++if HAVE_W32_SYSTEM
++./lock-obj-pub.native.h: Makefile gen-w32-lock-obj w32-lock-obj.h
++ ./gen-w32-lock-obj >$@
++else
+ ./lock-obj-pub.native.h: Makefile gen-posix-lock-obj posix-lock-obj.h
+ ./gen-posix-lock-obj >$@
+ endif
++endif
+
+ # We also depend on versioninfo.rc because that is build by
+ # config.status and thus has up-to-date version numbers.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60b61fdf1a6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+pkgname=mingw-w64-libgpg-error
+pkgver=1.19
+pkgrel=2
+pkgdesc="Support library for libgcrypt (mingw-w64)"
+arch=(any)
+url="http://www.gnupg.org"
+license=("LGPL")
+makedepends=(mingw-w64-configure)
+depends=(mingw-w64-gettext)
+options=(staticlibs !strip !buildflags)
+source=("ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${pkgver}.tar.bz2"{,.sig}
+"02-fix-symbollist-on.mingw.patch"
+"05-w32-gen.all.patch"
+"07-windows-build.patch")
+sha1sums=('4997951ab058788de48b989013668eb3df1e6939'
+ 'SKIP'
+ 'a7bbc4637aba322cd43aa7c5a6d99faa8f801133'
+ '07f1c34b3861bc2658d1cad4fafe895f654815df'
+ '367b3b33da0ae3a8f959ae8535d6584a997ad6b8')
+validpgpkeys=('D8692123C4065DEA5E0F3AB5249B39D24F25E3B6') # Werner Koch
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd libgpg-error-$pkgver
+ patch -p1 -i ${srcdir}/02-fix-symbollist-on.mingw.patch
+ patch -p1 -i ${srcdir}/05-w32-gen.all.patch
+ patch -p1 -i ${srcdir}/07-windows-build.patch
+
+ autoreconf -fi
+}
+
+build() {
+ cd "$srcdir/libgpg-error-$pkgver"
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libgpg-error-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}