summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-24 14:13:55 -0400
committerPatrick Northon2020-09-24 14:13:55 -0400
commit004ae3ab92a08cef0eb761b87338b5ac2d0e20fe (patch)
tree3705b8debcc825a0f11e8eb58bcca8a35bba54cd
parentf24d1f3d91ffe5e6977d902192a263353d71444c (diff)
downloadaur-004ae3ab92a08cef0eb761b87338b5ac2d0e20fe.tar.gz
Add fix for missing inline.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--fix-missing-inline.patch38
3 files changed, 49 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b286f394fa3..49299b930f38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libheif
pkgdesc = HEIF file format decoder and encoder. (mingw-w64)
pkgver = 1.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/strukturag/libheif
arch = any
license = LGPL
@@ -14,7 +14,9 @@ pkgbase = mingw-w64-libheif
options = !buildflags
options = staticlibs
source = https://github.com/strukturag/libheif/archive/v1.9.0.tar.gz
+ source = fix-missing-inline.patch
sha256sums = b9e1dde935675c451ff89517b46fe33d574fcbd0540c635296f512c7950c0dee
+ sha256sums = 9ae4197f1fe1d2c78b9612581636055ca8599ad4c5633c191d78b5391f43155a
pkgname = mingw-w64-libheif
diff --git a/PKGBUILD b/PKGBUILD
index 7014f3c43759..98dc56efd5ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libheif
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="HEIF file format decoder and encoder. (mingw-w64)"
url="https://github.com/strukturag/libheif"
license=("LGPL")
@@ -19,13 +19,20 @@ options=(!strip !buildflags staticlibs)
optdepends=()
sha256sums=(
"b9e1dde935675c451ff89517b46fe33d574fcbd0540c635296f512c7950c0dee"
+ "9ae4197f1fe1d2c78b9612581636055ca8599ad4c5633c191d78b5391f43155a"
)
source=(
"https://github.com/strukturag/libheif/archive/v${pkgver}.tar.gz"
+ "fix-missing-inline.patch"
)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "libheif-${pkgver}"
+ patch -uNp1 < "../fix-missing-inline.patch"
+}
+
build() {
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DWITH_EXAMPLES=OFF )
diff --git a/fix-missing-inline.patch b/fix-missing-inline.patch
new file mode 100644
index 000000000000..fc21d08febc1
--- /dev/null
+++ b/fix-missing-inline.patch
@@ -0,0 +1,38 @@
+diff --git a/libheif/heif_cxx.h b/libheif/heif_cxx.h
+index e05a730..c19199f 100644
+--- a/libheif/heif_cxx.h
++++ b/libheif/heif_cxx.h
+@@ -898,7 +898,7 @@ namespace heif {
+ }
+
+ // throws Error
+- ColorProfile_nclx Image::get_nclx_color_profile() const
++ inline ColorProfile_nclx Image::get_nclx_color_profile() const
+ {
+ heif_color_profile_nclx* nclx = nullptr;
+ Error err = Error(heif_image_get_nclx_color_profile(m_image.get(), &nclx));
+@@ -910,13 +910,13 @@ namespace heif {
+ }
+
+
+- heif_color_profile_type Image::get_color_profile_type() const
++ inline heif_color_profile_type Image::get_color_profile_type() const
+ {
+ return heif_image_get_color_profile_type(m_image.get());
+ }
+
+ // throws Error
+- std::vector<uint8_t> Image::get_raw_color_profile() const
++ inline std::vector<uint8_t> Image::get_raw_color_profile() const
+ {
+ auto size = heif_image_get_raw_color_profile_size(m_image.get());
+ std::vector<uint8_t> profile(size);
+@@ -924,7 +924,7 @@ namespace heif {
+ return profile;
+ }
+
+- void Image::set_raw_color_profile(heif_color_profile_type type,
++ inline void Image::set_raw_color_profile(heif_color_profile_type type,
+ const std::vector<uint8_t>& data)
+ {
+ const char* profile_type = nullptr;