summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-09-24 12:21:54 -0400
committerPatrick Northon2021-09-24 12:21:54 -0400
commit0e5110defe571182fac6fb7f03d45be5712aa6eb (patch)
tree8bb2edcc059466c2f8be0650d9fb6b8636494036
parent3663129fd83ec68850e07b703980274d0199050c (diff)
downloadaur-0e5110defe571182fac6fb7f03d45be5712aa6eb.tar.gz
Add static build in static prefix.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e17656fb1fa..7ba441bb6e2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libheif
pkgdesc = HEIF file format decoder and encoder (mingw-w64)
pkgver = 1.12.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/strukturag/libheif
arch = any
license = LGPL
@@ -16,8 +16,7 @@ pkgbase = mingw-w64-libheif
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/strukturag/libheif/archive/v1.12.0.tar.gz
+ source = mingw-w64-libheif-1.12.0.tar.gz::https://github.com/strukturag/libheif/archive/v1.12.0.tar.gz
sha256sums = 086145b0d990182a033b0011caadb1b642da84f39ab83aa66d005610650b3c65
pkgname = mingw-w64-libheif
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fcdfe204791..c46ff10c5848 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libheif
pkgver=1.12.0
-pkgrel=3
+pkgrel=4
pkgdesc="HEIF file format decoder and encoder (mingw-w64)"
url="https://github.com/strukturag/libheif"
license=("LGPL")
@@ -23,7 +23,7 @@ sha256sums=(
'086145b0d990182a033b0011caadb1b642da84f39ab83aa66d005610650b3c65'
)
source=(
- "https://github.com/strukturag/libheif/archive/v${pkgver}.tar.gz"
+ "$pkgname-$pkgver.tar.gz::https://github.com/strukturag/libheif/archive/v${pkgver}.tar.gz"
)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -32,6 +32,9 @@ build() {
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DCMAKE_CXX_STANDARD_LIBRARIES="-lws2_32 -lwsock32 -luserenv" -DWITH_EXAMPLES=OFF )
for _arch in ${_architectures}; do
+ ${_arch}-cmake -S "libheif-${pkgver}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=OFF -DCMAKE_INSTALL_PREFIX="/usr/${_arch}/static"
+ cmake --build "build-${_arch}-static"
+
${_arch}-cmake -S "libheif-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
cmake --build "build-${_arch}"
done
@@ -39,6 +42,9 @@ build() {
package() {
for _arch in ${_architectures}; do
+ DESTDIR="${pkgdir}" cmake --install "build-${_arch}-static"
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/static/lib/*.a
+
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a