summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-02-02 05:09:56 -0500
committerPatrick Northon2021-02-02 05:09:56 -0500
commitff4b87a1b79e7f450c2d5650119e1a392d2f5ccf (patch)
tree2158e9160f8be07155b25bf8907696a8bc91d4a9
parent5270b221ac961554fecc30fb3ddc85e21777e9e0 (diff)
downloadaur-ff4b87a1b79e7f450c2d5650119e1a392d2f5ccf.tar.gz
Fix linking and bump version.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12821971a7e4..4f99adcbbe50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libheif
pkgdesc = HEIF file format decoder and encoder. (mingw-w64)
- pkgver = 1.10.0
- pkgrel = 2
+ pkgver = 1.11.0
+ pkgrel = 1
url = https://github.com/strukturag/libheif
arch = any
license = LGPL
@@ -14,8 +14,8 @@ pkgbase = mingw-w64-libheif
options = !strip
options = !buildflags
options = staticlibs
- source = https://github.com/strukturag/libheif/archive/v1.10.0.tar.gz
- sha256sums = 317a44bf157ba297638ab5a258040ef6ec4895d620cd58f52195f3f89c9eea28
+ source = https://github.com/strukturag/libheif/archive/v1.11.0.tar.gz
+ sha256sums = 993c3320e179b8fdce983e3a7e96615af3830077be6b0ab28bfa25579df08d26
pkgname = mingw-w64-libheif
diff --git a/PKGBUILD b/PKGBUILD
index 0a74e94fe8b2..415b679a2b2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=mingw-w64-libheif
-pkgver=1.10.0
-pkgrel=2
+pkgver=1.11.0
+pkgrel=1
pkgdesc="HEIF file format decoder and encoder. (mingw-w64)"
url="https://github.com/strukturag/libheif"
license=("LGPL")
@@ -18,7 +18,7 @@ arch=("any")
options=(!strip !buildflags staticlibs)
optdepends=()
sha256sums=(
- "317a44bf157ba297638ab5a258040ef6ec4895d620cd58f52195f3f89c9eea28"
+ "993c3320e179b8fdce983e3a7e96615af3830077be6b0ab28bfa25579df08d26"
)
source=(
"https://github.com/strukturag/libheif/archive/v${pkgver}.tar.gz"
@@ -27,7 +27,7 @@ source=(
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DWITH_EXAMPLES=OFF )
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DCMAKE_CXX_STANDARD_LIBRARIES="-lws2_32 -lwsock32 -luserenv" -DWITH_EXAMPLES=OFF )
for _arch in ${_architectures}; do
${_arch}-cmake -S "libheif-${pkgver}" -B "build-${_arch}" "${_flags[@]}"