summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-08-02 21:38:55 +0200
committerxantares2015-08-02 21:38:55 +0200
commit0e9db73a9ba28ad9b93f072efbef2883337fb1ab (patch)
treecd5a88b39cbe667284e9faa8c2fad0eea5ce5d49
downloadaur-0e9db73a9ba28ad9b93f072efbef2883337fb1ab.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e91bdcf035c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-libidn
+ pkgdesc = Implementation of the Stringprep, Punycode and IDNA specifications (mingw-w64)
+ pkgver = 1.29
+ pkgrel = 1
+ url = http://www.gnu.org/software/libidn
+ arch = any
+ license = GPL3, LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ depends = mingw-w64-gettext
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://ftp.gnu.org/gnu/libidn/libidn-1.29.tar.gz
+ sha1sums = e0959eec9a03fd8053379b0aeab447c546c05ab2
+
+pkgname = mingw-w64-libidn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8f188e745c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=mingw-w64-libidn
+pkgver=1.29
+pkgrel=1
+pkgdesc="Implementation of the Stringprep, Punycode and IDNA specifications (mingw-w64)"
+arch=(any)
+url="http://www.gnu.org/software/libidn"
+license=("GPL3, LGPL")
+makedepends=(mingw-w64-configure)
+depends=(mingw-w64-crt mingw-w64-gettext)
+options=(staticlibs !strip !buildflags)
+source=("http://ftp.gnu.org/gnu/libidn/libidn-${pkgver}.tar.gz")
+sha1sums=('e0959eec9a03fd8053379b0aeab447c546c05ab2')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/libidn-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --disable-csharp --disable-java
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libidn-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/usr/${_arch}/share"
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ rm "$pkgdir"/usr/${_arch}/bin/*.def
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}