summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexdiaconescu2015-06-12 19:27:40 +0300
committeralexdiaconescu2015-06-12 19:27:40 +0300
commitb89d055f81fc3e3cd8c103b1cda7441949ef95ef (patch)
tree2bdd529ce806a2f627e5cb2c7108147fa3b2a66c
downloadaur-b89d055f81fc3e3cd8c103b1cda7441949ef95ef.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--ChangeLog13
-rw-r--r--PKGBUILD37
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ef94181691c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-liblo
+ pkgdesc = A lightweight OSC (Open Sound Control) implementation (mingw-w64)
+ pkgver = 0.28
+ pkgrel = 3
+ url = http://liblo.sourceforge.net/
+ changelog = ChangeLog
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://downloads.sourceforge.net/project/liblo/liblo/0.28/liblo-0.28.tar.gz
+ md5sums = e2a4391a08b49bb316c03e2034e06fa2
+
+pkgname = mingw-w64-liblo
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..d7ef27d8a22e
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,13 @@
+2015-01-14 Joermungand <jeormungand at gmail dot com>
+
+ * 0.28-3 :
+ changed CFLAGS in build() function
+
+2014-10-28 Joermungand <jeormungand at gmail dot com>
+
+ * 0.28-2 :
+ added ChangeLog.
+ arch changed to 'any'.
+ exe files removed.
+ removed redundant dependency mingw-w64-gcc.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e9ffe49bf39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Joermungand <joermungand at gmail dot com>
+pkgname=mingw-w64-liblo
+pkgver=0.28
+pkgrel=3
+pkgdesc="A lightweight OSC (Open Sound Control) implementation (mingw-w64)"
+arch=('any')
+url="http://liblo.sourceforge.net/"
+license=('LGPL')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('!strip' '!buildflags' 'staticlibs')
+changelog=ChangeLog
+source=("http://downloads.sourceforge.net/project/${pkgname##*-}/${pkgname##*-}/$pkgver/${pkgname##*-}-$pkgver.tar.gz")
+md5sums=('e2a4391a08b49bb316c03e2034e06fa2')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ export CFLAGS="-Wno-error"
+ cd "${srcdir}/${pkgname##*-}-$pkgver/"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname##*-}-$pkgver/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ done
+}