summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-02-08 16:09:38 +0800
committerpingplug2018-02-08 16:09:38 +0800
commit79704f2a7df6e3ff8961c59688d63d4b0c79e545 (patch)
treedfcdd7cd640cf8d902304f92538513391253beb4
parentd171f70eee5dd86b5db5aa67a1b583cea1869327 (diff)
downloadaur-79704f2a7df6e3ff8961c59688d63d4b0c79e545.tar.gz
Add static libaray back
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD12
3 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4115f233f087..c5ef06be7dab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Fri Feb 2 16:59:49 UTC 2018
pkgbase = mingw-w64-libmpc
pkgdesc = Library for the arithmetic of complex numbers with arbitrarily high precision (mingw-w64)
pkgver = 1.1.0
- pkgrel = 1
- url = http://www.multiprecision.org
+ pkgrel = 2
+ url = http://www.multiprecision.org/mpc/
arch = any
license = LGPL
makedepends = mingw-w64-configure
@@ -14,6 +12,7 @@ pkgbase = mingw-w64-libmpc
options = !buildflags
source = https://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz
source = https://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz.sig
+ validpgpkeys = AD17A21EF8AED8F1CC02DBD9F7D5C9BF765C61E3
sha256sums = 6985c538143c1208dcb1ac42cedad6ff52e267b47e5f970183a3e75125b43c2e
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..97589fb4de69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/PKGBUILD b/PKGBUILD
index 897bf7d34adf..c0842ccd61bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: xantares <xantares09@hotmail.com>
+
pkgname=mingw-w64-libmpc
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Library for the arithmetic of complex numbers with arbitrarily high precision (mingw-w64)"
arch=(any)
-url="http://www.multiprecision.org"
+url="http://www.multiprecision.org/mpc/"
license=("LGPL")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-mpfr)
options=(!libtool !strip !buildflags)
-source=("http://www.multiprecision.org/mpc/download/mpc-${pkgver/_/-}.tar.gz"{,.sig})
source=(https://ftp.gnu.org/gnu/mpc/mpc-${pkgver}.tar.gz{,.sig})
sha256sums=('6985c538143c1208dcb1ac42cedad6ff52e267b47e5f970183a3e75125b43c2e'
'SKIP')
@@ -20,9 +22,7 @@ build() {
cd mpc-${pkgver}
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- $_arch-configure \
- --enable-shared \
- --disable-static
+ $_arch-configure
make
popd
done