summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2019-05-21 14:27:29 +0800
committerpingplug2019-05-21 14:27:29 +0800
commit80520db0214b8ebcf88a3177a786bd3849e38859 (patch)
treee054f2cefd35a2119e4d7f2f9f6fd21018bf0eef
parent79704f2a7df6e3ff8961c59688d63d4b0c79e545 (diff)
downloadaur-80520db0214b8ebcf88a3177a786bd3849e38859.tar.gz
update email
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5ef06be7dab..eeb0f6179705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,8 +7,8 @@ pkgbase = mingw-w64-libmpc
license = LGPL
makedepends = mingw-w64-configure
depends = mingw-w64-mpfr
- options = !libtool
options = !strip
+ options = staticlibs
options = !buildflags
source = https://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz
source = https://ftp.gnu.org/gnu/mpc/mpc-1.1.0.tar.gz.sig
diff --git a/PKGBUILD b/PKGBUILD
index c0842ccd61bc..3581908ae3f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
-# Maintainer: pingplug <pingplug@foxmail.com>
-# Contributor: xantares <xantares09@hotmail.com>
+# Maintainer: pingplug < aur at pingplug dot me >
+# Contributor: xantares < xantares09 at hotmail dot com >
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgname=mingw-w64-libmpc
pkgver=1.1.0
pkgrel=2
pkgdesc="Library for the arithmetic of complex numbers with arbitrarily high precision (mingw-w64)"
-arch=(any)
+arch=('any')
url="http://www.multiprecision.org/mpc/"
-license=("LGPL")
-makedepends=(mingw-w64-configure)
-depends=(mingw-w64-mpfr)
-options=(!libtool !strip !buildflags)
-source=(https://ftp.gnu.org/gnu/mpc/mpc-${pkgver}.tar.gz{,.sig})
+license=('LGPL')
+depends=('mingw-w64-mpfr')
+makedepends=('mingw-w64-configure')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("https://ftp.gnu.org/gnu/mpc/mpc-${pkgver}.tar.gz"{,.sig})
sha256sums=('6985c538143c1208dcb1ac42cedad6ff52e267b47e5f970183a3e75125b43c2e'
'SKIP')
-validpgpkeys=('AD17A21EF8AED8F1CC02DBD9F7D5C9BF765C61E3') # Andreas Enge
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+validpgpkeys=('AD17A21EF8AED8F1CC02DBD9F7D5C9BF765C61E3') # Andreas Enge <andreas@enge.fr>
build() {
cd mpc-${pkgver}
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- $_arch-configure
+ ${_arch}-configure
make
popd
done
@@ -31,9 +31,11 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/mpc-${pkgver}/build-${_arch}"
- make DESTDIR="$pkgdir" install
- rm -r "$pkgdir/usr/${_arch}/share"
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/${_arch}/share"
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
}
+
+# vim:set ts=2 sw=2 et: