summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-25 00:50:11 +0200
committerxantares2015-07-25 00:50:11 +0200
commit4be6a8c4546385cb44fece957ef6f38dd1cbcd1d (patch)
treeb60f5fac79bd7a00fe821410d937393c7641a8ef
parentd4e812596b5b119d5a71361b17b57b89febb14fa (diff)
downloadaur-4be6a8c4546385cb44fece957ef6f38dd1cbcd1d.tar.gz
v1.6.17
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daa9cc6d0235..129de597147a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = mingw-w64-libpng
pkgdesc = A collection of routines used to create PNG format graphics (mingw-w64)
- pkgver = 1.6.16
+ pkgver = 1.6.17
pkgrel = 1
url = http://www.libpng.org/pub/png/libpng.html
arch = any
license = custom
- makedepends = mingw-w64-gcc
makedepends = mingw-w64-configure
depends = mingw-w64-zlib
depends = mingw-w64-crt
options = !strip
options = !buildflags
options = staticlibs
- source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.16.tar.xz
- source = http://downloads.sourceforge.net/project/libpng-apng/libpng16/1.6.16/libpng-1.6.16-apng.patch.gz
- md5sums = 23b7286b5d4a86de950fd2ffc5cac742
- md5sums = 52de72a29e5d0428a0e527be74b99c24
+ source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.17.tar.xz
+ source = http://downloads.sourceforge.net/project/libpng-apng/libpng16/1.6.17/libpng-1.6.17-apng.patch.gz
+ md5sums = 430a9b76b78533235cd4b9b26ce75c7e
+ md5sums = f68d34f10bcc7f43b8c3dce5708e1933
pkgname = mingw-w64-libpng
diff --git a/PKGBUILD b/PKGBUILD
index fd3149ab302a..8107079ce830 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,37 @@
-# Maintainer: Daniel Kirchner <daniel AT ekpyron DOT org>
+# Contributor: Daniel Kirchner <daniel AT ekpyron DOT org>
pkgname=mingw-w64-libpng
-pkgver=1.6.16
+pkgver=1.6.17
pkgrel=1
arch=('any')
pkgdesc="A collection of routines used to create PNG format graphics (mingw-w64)"
depends=('mingw-w64-zlib' 'mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
+makedepends=('mingw-w64-configure')
license=('custom')
url="http://www.libpng.org/pub/png/libpng.html"
-options=(!strip !buildflags staticlibs)
+options=('!strip' '!buildflags' 'staticlibs')
source=("http://downloads.sourceforge.net/sourceforge/libpng/libpng-$pkgver.tar.xz"
"http://downloads.sourceforge.net/project/libpng-apng/libpng16/$pkgver/libpng-$pkgver-apng.patch.gz")
-md5sums=('23b7286b5d4a86de950fd2ffc5cac742'
- '52de72a29e5d0428a0e527be74b99c24')
+md5sums=('430a9b76b78533235cd4b9b26ce75c7e'
+ 'f68d34f10bcc7f43b8c3dce5708e1933')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-build() {
+prepare() {
cd "$srcdir/libpng-$pkgver"
# Add animated PNG (apng) support
# see http://sourceforge.net/projects/libpng-apng/
patch -p1 -i "${srcdir}/libpng-$pkgver-apng.patch"
+}
+build() {
+ cd "$srcdir/libpng-$pkgver"
for _arch in ${_architectures}; do
- mkdir -p "${srcdir}/libpng-${pkgver}/build-${_arch}"
- cd "${srcdir}/libpng-${pkgver}/build-${_arch}"
+ mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure
make
+ popd
done
}
@@ -36,10 +39,10 @@ package () {
for _arch in ${_architectures}; do
cd "${srcdir}/libpng-${pkgver}/build-${_arch}"
make install DESTDIR="${pkgdir}"
- rm -rf "${pkgdir}/usr/${_arch}/share/man"
- ${_arch}-strip -x -g "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ rm -rf "${pkgdir}"/usr/${_arch}/share
+ rm "${pkgdir}"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
done
-
install -D -m644 "${srcdir}/libpng-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}