summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-20 20:17:51 +0200
committerxantares2015-07-20 20:17:51 +0200
commitd4e812596b5b119d5a71361b17b57b89febb14fa (patch)
tree81bfab408c7be1be8a4586f6f024b2d70972dc18
downloadaur-d4e812596b5b119d5a71361b17b57b89febb14fa.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..daa9cc6d0235
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mingw-w64-libpng
+ pkgdesc = A collection of routines used to create PNG format graphics (mingw-w64)
+ pkgver = 1.6.16
+ pkgrel = 1
+ url = http://www.libpng.org/pub/png/libpng.html
+ arch = any
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-zlib
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/libpng/libpng-1.6.16.tar.xz
+ source = http://downloads.sourceforge.net/project/libpng-apng/libpng16/1.6.16/libpng-1.6.16-apng.patch.gz
+ md5sums = 23b7286b5d4a86de950fd2ffc5cac742
+ md5sums = 52de72a29e5d0428a0e527be74b99c24
+
+pkgname = mingw-w64-libpng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd3149ab302a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Daniel Kirchner <daniel AT ekpyron DOT org>
+
+pkgname=mingw-w64-libpng
+pkgver=1.6.16
+pkgrel=1
+arch=('any')
+pkgdesc="A collection of routines used to create PNG format graphics (mingw-w64)"
+depends=('mingw-w64-zlib' 'mingw-w64-crt')
+makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
+license=('custom')
+url="http://www.libpng.org/pub/png/libpng.html"
+options=(!strip !buildflags staticlibs)
+source=("http://downloads.sourceforge.net/sourceforge/libpng/libpng-$pkgver.tar.xz"
+ "http://downloads.sourceforge.net/project/libpng-apng/libpng16/$pkgver/libpng-$pkgver-apng.patch.gz")
+md5sums=('23b7286b5d4a86de950fd2ffc5cac742'
+ '52de72a29e5d0428a0e527be74b99c24')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir/libpng-$pkgver"
+
+ # Add animated PNG (apng) support
+ # see http://sourceforge.net/projects/libpng-apng/
+ patch -p1 -i "${srcdir}/libpng-$pkgver-apng.patch"
+
+ for _arch in ${_architectures}; do
+ mkdir -p "${srcdir}/libpng-${pkgver}/build-${_arch}"
+ cd "${srcdir}/libpng-${pkgver}/build-${_arch}"
+ ${_arch}-configure
+ make
+ done
+}
+
+package () {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libpng-${pkgver}/build-${_arch}"
+ make install DESTDIR="${pkgdir}"
+ rm -rf "${pkgdir}/usr/${_arch}/share/man"
+ ${_arch}-strip -x -g "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
+ done
+
+ install -D -m644 "${srcdir}/libpng-${pkgver}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}