summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-09-04 14:19:31 +0200
committerNicola Murino2018-09-04 14:19:31 +0200
commit1d0ca3a23905a3d3b8e0d975acd03584b9e5c63b (patch)
tree8fbd800d2a689b0926cee28536ed97c0672f0ee1
downloadaur-1d0ca3a23905a3d3b8e0d975acd03584b9e5c63b.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc1e8f2c7ee8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Sep 4 12:19:14 UTC 2018
+pkgbase = mingw-w64-libpsl
+ pkgdesc = Public Suffix List library
+ pkgver = 0.20.2
+ pkgrel = 1
+ url = https://github.com/rockdaboot/libpsl
+ arch = any
+ license = MIT
+ makedepends = mingw-w64-configure
+ makedepends = python
+ depends = mingw-w64-libidn2
+ depends = mingw-w64-libunistring
+ depends = mingw-w64-gcc
+ source = https://github.com/rockdaboot/libpsl/releases/download/libpsl-0.20.2/libpsl-0.20.2.tar.gz
+ sha512sums = fa9f6f7f0447d9fe00f5dfca5262c56ff26217eea44d0f7fc1e5d982224c41874e753f0aa06dd9e5d7d03d4f04e3dacd4f36034cc8dd0fc6e2c28b49a23e62fe
+
+pkgname = mingw-w64-libpsl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b2de080f238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+
+pkgname=mingw-w64-libpsl
+_pkgname=libpsl
+pkgver=0.20.2
+pkgrel=1
+pkgdesc='Public Suffix List library'
+url='https://github.com/rockdaboot/libpsl'
+arch=(any)
+license=('MIT')
+depends=('mingw-w64-libidn2' 'mingw-w64-libunistring' 'mingw-w64-gcc')
+makedepends=('mingw-w64-configure' 'python')
+source=(https://github.com/rockdaboot/libpsl/releases/download/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz)
+sha512sums=('fa9f6f7f0447d9fe00f5dfca5262c56ff26217eea44d0f7fc1e5d982224c41874e753f0aa06dd9e5d7d03d4f04e3dacd4f36034cc8dd0fc6e2c28b49a23e62fe')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ export LIBS=-lws2_32
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --disable-gtk-doc-html \
+ --disable-man \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ done
+}
+
+# vim: ts=2 sw=2 et