summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-05 16:48:21 -0400
committerPatrick Northon2020-09-05 16:48:21 -0400
commit0283a466732544827fec1aa8a10e28fc7c20f4ae (patch)
tree2fa2c2d5853ba362e4426e0cbcf45776d255df26
downloadaur-0283a466732544827fec1aa8a10e28fc7c20f4ae.tar.gz
Initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD54
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58432960d6f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-libraw
+ pkgdesc = LibRaw is a library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (mingw-w64)
+ pkgver = 0.20.0
+ pkgrel = 1
+ url = https://github.com/strukturag/libheif
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-make
+ makedepends = git
+ depends = mingw-w64-crt
+ depends = mingw-w64-lcms2
+ depends = mingw-w64-libjpeg-turbo
+ depends = mingw-w64-jasper
+ depends = mingw-w64-zlib
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/LibRaw/LibRaw/archive/0.20.0.tar.gz
+ source = git+https://github.com/LibRaw/LibRaw-cmake
+ sha256sums = f38cd2620d5adc32d2c9f51cd0dc66d72c75671f1c81dfd13d30c45c6be80d40
+ sha256sums = SKIP
+
+pkgname = mingw-w64-libraw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a026ebaafe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=mingw-w64-libraw
+pkgver=0.20.0
+pkgrel=1
+pkgdesc="LibRaw is a library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (mingw-w64)"
+url="https://github.com/strukturag/libheif"
+license=("LGPL")
+depends=(
+ "mingw-w64-crt"
+ "mingw-w64-lcms2"
+ "mingw-w64-libjpeg-turbo"
+ "mingw-w64-jasper"
+ "mingw-w64-zlib"
+)
+makedepends=("mingw-w64-make" "git")
+arch=("any")
+options=(!strip !buildflags staticlibs)
+optdepends=()
+sha256sums=(
+ "f38cd2620d5adc32d2c9f51cd0dc66d72c75671f1c81dfd13d30c45c6be80d40"
+ "SKIP"
+)
+source=(
+ "https://github.com/LibRaw/LibRaw/archive/${pkgver}.tar.gz"
+ "git+https://github.com/LibRaw/LibRaw-cmake"
+)
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ mv -f "LibRaw-cmake"/* "LibRaw-${pkgver}/"
+}
+
+build() {
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DENABLE_EXAMPLES=OFF )
+
+ for _arch in ${_architectures}; do
+ ${_arch}-cmake -S "LibRaw-${pkgver}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=FALSE
+ make -C "build-${_arch}-static"
+ ${_arch}-cmake -S "LibRaw-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
+ make -C "build-${_arch}"
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
+ make DESTDIR="${pkgdir}" -C "build-${_arch}" install
+ mv "${pkgdir}/usr/share" "${pkgdir}/usr/${_arch}/"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}