summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2020-09-10 02:07:33 -0400
committerPatrick Northon2020-09-10 02:07:33 -0400
commit83b40865890e5144b2c4206e18a45e9d193e21e2 (patch)
treefe4bb82285d2f73dc5e8dc2be5b96b1124259a18
parent0283a466732544827fec1aa8a10e28fc7c20f4ae (diff)
downloadaur-83b40865890e5144b2c4206e18a45e9d193e21e2.tar.gz
Remove static build as it conflicts.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 2 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58432960d6f0..783dde61bd61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-libraw
pkgdesc = LibRaw is a library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (mingw-w64)
pkgver = 0.20.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/strukturag/libheif
arch = any
license = LGPL
diff --git a/PKGBUILD b/PKGBUILD
index 7a026ebaafe0..87db7979b4c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libraw
pkgver=0.20.0
-pkgrel=1
+pkgrel=2
pkgdesc="LibRaw is a library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others) (mingw-w64)"
url="https://github.com/strukturag/libheif"
license=("LGPL")
@@ -36,8 +36,6 @@ build() {
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DENABLE_EXAMPLES=OFF )
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "LibRaw-${pkgver}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=FALSE
- make -C "build-${_arch}-static"
${_arch}-cmake -S "LibRaw-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
make -C "build-${_arch}"
done
@@ -45,10 +43,8 @@ build() {
package() {
for _arch in ${_architectures}; do
- make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
make DESTDIR="${pkgdir}" -C "build-${_arch}" install
mv "${pkgdir}/usr/share" "${pkgdir}/usr/${_arch}/"
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}