summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Kozik2019-05-14 17:18:53 +0200
committerAndrew Kozik2019-05-14 17:18:53 +0200
commit43a731e081452e88219ecc3ef1bb4d84c1ebac84 (patch)
tree3c7c61bf09dda6f5edd53b22f6ec9438fc71d874
downloadaur-43a731e081452e88219ecc3ef1bb4d84c1ebac84.tar.gz
Saw there was no LibreSSL Mingw package on the AUR so tried to put something together
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD45
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3e2bfed33cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-libressl-portable-git
+ pkgdesc = LibreSSL is an open-source implementation of the Transport Layer Security protocol (mingw-w64)
+ pkgver = v2.1.3.r787.ga2befe3
+ pkgrel = 1
+ url = https://www.libressl.org
+ arch = any
+ license = Apache 1.0
+ license = 4-clause BSD
+ license = ISC
+ license = public domain
+ makedepends = mingw-w64-gcc
+ makedepends = perl
+ provides = mingw-w64-openssl
+ conflicts = mingw-w64-openssl
+ options = !strip
+ options = staticlibs
+ options = !buildflags
+ source = libressl-portable::git+https://github.com/libressl-portable/portable/
+ sha256sums = SKIP
+
+pkgname = mingw-w64-libressl-portable-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d3349ec8581
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andrew Kozik <andrewkoz at live dot com>
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+pkgname=mingw-w64-libressl-portable-git
+pkgver=v2.1.3.r787.ga2befe3
+pkgrel=1
+_gitname=libressl-portable
+pkgdesc="LibreSSL is an open-source implementation of the Transport Layer Security protocol (mingw-w64)"
+arch=('any')
+url="https://www.libressl.org"
+license=('Apache 1.0' '4-clause BSD' 'ISC' 'public domain')
+depends=()
+makedepends=('mingw-w64-gcc'
+ 'perl')
+options=('!strip' 'staticlibs' '!buildflags')
+conflicts=('mingw-w64-openssl')
+provides=('mingw-w64-openssl')
+
+source=("${_gitname}::git+https://github.com/${_gitname}/portable/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ for _arch in $_architectures; do
+ mkdir -p "${srcdir}/build-${_arch}" && cp -a "${srcdir}/${_gitname}/"* "${srcdir}/build-${_arch}" && cd "${srcdir}/build-${_arch}"
+ ./autogen.sh
+ CC="${_arch}-gcc" CPPFLAGS="-D__MINGW_USE_VC2005_COMPAT" ./configure --host=${_arch} --prefix=/usr/${_arch}
+ make
+ ## make check
+ done
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/build-${_arch}"
+ DESTDIR="${pkgdir}" make install
+ done
+}