summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-10-10 13:24:06 -0700
committerBuildTools2015-10-10 13:24:06 -0700
commit2c09e4f2156fa9be00ec92577308514bad20e75f (patch)
tree80ea67d047b99b056de1d5e910269ea1a955b00e
downloadaur-2c09e4f2156fa9be00ec92577308514bad20e75f.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08962165bbb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = mingw-w64-librsvg
+ pkgdesc = A SVG viewing library (mingw-w64)
+ pkgver = 2.40.11
+ pkgrel = 1
+ url = https://live.gnome.org/LibRsvg
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-configure
+ makedepends = gdk-pixbuf2
+ makedepends = intltool
+ makedepends = setconf
+ depends = mingw-w64-gdk-pixbuf2
+ depends = mingw-w64-pango
+ depends = mingw-w64-libcroco
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://ftp.gnome.org/pub/gnome/sources/librsvg/2.40/librsvg-2.40.11.tar.xz
+ sha256sums = 611ac0f544debd0c9bf1ef5509c990d218e83dd1d8c83297075c4b29796a2e02
+
+pkgname = mingw-w64-librsvg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f46de972b6fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01bfc10809cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=mingw-w64-librsvg
+pkgver=2.40.11
+pkgrel=1
+pkgdesc="A SVG viewing library (mingw-w64)"
+arch=(any)
+url="https://live.gnome.org/LibRsvg"
+license=("LGPL")
+makedepends=(mingw-w64-configure gdk-pixbuf2 intltool setconf)
+depends=(mingw-w64-gdk-pixbuf2 mingw-w64-pango mingw-w64-libcroco)
+options=(staticlibs !strip !buildflags)
+source=("http://ftp.gnome.org/pub/gnome/sources/librsvg/${pkgver%.*}/librsvg-$pkgver.tar.xz")
+sha256sums=('611ac0f544debd0c9bf1ef5509c990d218e83dd1d8c83297075c4b29796a2e02')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd librsvg-$pkgver
+ CXXFLAGS+=" -D_POSIX_SOURCE"
+ CFLAGS+=" -D_POSIX_SOURCE"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --disable-introspection \
+ --disable-tools
+ setconf Makefile AM_CFLAGS '-fno-common'
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/librsvg-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+}