summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2020-05-17 18:00:32 +0100
committerAlexandros Theodotou2020-05-17 18:00:32 +0100
commit9f579b68dcec82f1db8dc090f85c6abc3069ec67 (patch)
tree47403e1713c1dbdc5ad3d6101d9303bf243e2ea8
downloadaur-9f579b68dcec82f1db8dc090f85c6abc3069ec67.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b04bc21a8cac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-librsvg-bin
+ pkgdesc = SVG rendering library (mingw-w64)
+ pkgver = 2.48.4
+ pkgrel = 1
+ url = https://www.gnome.org
+ arch = any
+ license = custom
+ depends = mingw-w64-gdk-pixbuf2
+ depends = mingw-w64-pango
+ depends = mingw-w64-cairo
+ depends = mingw-w64-libxml2
+ provides = mingw-w64-librsvg
+ source = http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-librsvg-2.48.4-2-any.pkg.tar.zst
+ sha256sums = SKIP
+
+pkgname = mingw-w64-librsvg-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..778ff2be9c9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=mingw-w64-librsvg-bin
+pkgver=2.48.4
+pkgrel=1
+pkgdesc="SVG rendering library (mingw-w64)"
+arch=('any')
+url="https://www.gnome.org"
+license=('custom')
+depends=('mingw-w64-gdk-pixbuf2'
+ 'mingw-w64-pango'
+ 'mingw-w64-cairo'
+ 'mingw-w64-libxml2')
+provides=('mingw-w64-librsvg')
+source=("http://repo.msys2.org/mingw/x86_64/mingw-w64-x86_64-librsvg-2.48.4-2-any.pkg.tar.zst")
+sha256sums=('SKIP')
+
+_architectures="x86_64-w64-mingw32"
+
+package() {
+ cd "${srcdir}/mingw64"
+ for _arch in ${_architectures}; do
+ mkdir -p ./* $pkgdir/usr/${_arch}/
+ sed -i -e "s|/mingw64|/usr/${_arch}|" ./lib/pkgconfig/*
+ cp -r ./* $pkgdir/usr/${_arch}/
+ done
+}