summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2021-08-07 10:54:09 +0200
committerMichel Zou2021-08-07 10:54:09 +0200
commita8a0a79d7cd1f1153cb599b7a4b42844c098ddb9 (patch)
tree2c7f86ed4150ce943bcf4801bfcf3206bdbe94c0
downloadaur-mingw-w64-librttopo.tar.gz
1.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32427457b266
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mingw-w64-librttopo
+ pkgdesc = RT Topology Library (mingw-w64)
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://git.osgeo.org/gitea/rttopo/librttopo
+ arch = any
+ license = GPL2
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-geos
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = https://git.osgeo.org/gitea/rttopo/librttopo/archive/librttopo-1.1.0.tar.gz
+ sha256sums = 2e2fcabb48193a712a6c76ac9a9be2a53f82e32f91a2bc834d9f1b4fa9cd879f
+
+pkgname = mingw-w64-librttopo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..921a5844ef3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=mingw-w64-librttopo
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="RT Topology Library (mingw-w64)"
+arch=('any')
+url="https://git.osgeo.org/gitea/rttopo/librttopo"
+license=('GPL2')
+depends=('mingw-w64-geos')
+makedepends=('mingw-w64-configure')
+options=('!buildflags' 'staticlibs' '!strip')
+source=(https://git.osgeo.org/gitea/rttopo/librttopo/archive/librttopo-$pkgver.tar.gz)
+sha256sums=('2e2fcabb48193a712a6c76ac9a9be2a53f82e32f91a2bc834d9f1b4fa9cd879f')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}"/librttopo
+ ./autogen.sh
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure --with-geosconfig=/usr/${_arch}/bin/geos-config ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/librttopo/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+