summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjulienCXX2015-07-23 14:38:50 +0200
committerjulienCXX2015-07-23 14:38:50 +0200
commitba3a131ba6364ee5405125a3a6765c34a2b6b9b5 (patch)
treefe7e66cd0f2be88ccce6253a1bc4838ebddd1653
downloadaur-mingw-w64-libsearpc.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
-rw-r--r--libsearpc.pc.patch8
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee67464f4a0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mingw-w64-libsearpc
+ pkgdesc = A simple and easy-to-use C language RPC framework (including both server side & client side) based on GObject System (mingw-w64).
+ pkgver = 3.0.latest
+ pkgrel = 4
+ url = https://github.com/haiwen/libsearpc/
+ arch = any
+ license = GPL3
+ makedepends = mingw-w64-configure
+ makedepends = libtool>1.4
+ makedepends = python2>=2.4
+ depends = mingw-w64-crt
+ depends = mingw-w64-glib2>=2.26.0
+ depends = mingw-w64-jansson>=2.2.1
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = libsearpc-3.0.latest.tar.gz::https://github.com/haiwen/libsearpc/archive/v3.0-latest.tar.gz
+ source = libsearpc.pc.patch
+ sha256sums = 56313771e0ad7dc075c4590b6a75daeb3939937b21716d82c91be2612133b8cd
+ sha256sums = aec39a303aaebc0777a22d8c53367f52f619654d63f62b362d75c1c599e632f4
+
+pkgname = mingw-w64-libsearpc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6c8cf38f33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: julienCXX <archlinux@chmodplusx.eu>
+
+# Contributor: Moritz Maxeiner <moritz@ucworks.org>
+# Contributor: Aaron Lindsay <aaron@aclindsay.com>
+
+pkgname=mingw-w64-libsearpc
+_basever=3.0
+_remotever=$_basever-latest
+pkgver=$_basever.latest
+pkgrel=4
+pkgdesc="A simple and easy-to-use C language RPC framework (including both
+server side & client side) based on GObject System (mingw-w64)."
+arch=('any')
+url="https://github.com/haiwen/libsearpc/"
+license=('GPL3')
+makedepends=('mingw-w64-configure' 'libtool>1.4' 'python2>=2.4')
+depends=('mingw-w64-crt' 'mingw-w64-glib2>=2.26.0' 'mingw-w64-jansson>=2.2.1')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("libsearpc-${pkgver}.tar.gz::https://github.com/haiwen/libsearpc/archive/v${_remotever}.tar.gz"
+ "libsearpc.pc.patch")
+sha256sums=('56313771e0ad7dc075c4590b6a75daeb3939937b21716d82c91be2612133b8cd'
+ 'aec39a303aaebc0777a22d8c53367f52f619654d63f62b362d75c1c599e632f4')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir/libsearpc-$_remotever"
+ patch -p1 -i $srcdir/libsearpc.pc.patch
+}
+
+build() {
+ cd "$srcdir/libsearpc-$_remotever"
+ ./autogen.sh
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure --enable-compile-demo=no PYTHON=python2
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libsearpc-${_remotever}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
+}
diff --git a/libsearpc.pc.patch b/libsearpc.pc.patch
new file mode 100644
index 000000000000..aaff6b250e79
--- /dev/null
+++ b/libsearpc.pc.patch
@@ -0,0 +1,8 @@
+--- a/libsearpc.pc.in 2013-01-10 01:35:24.000000000 -0500
++++ b/libsearpc.pc.in 2013-01-19 11:31:50.479301798 -0500
+@@ -1,4 +1,4 @@
+-prefix=(DESTDIR)@prefix@
++prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@