summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-07-21 20:05:01 +0200
committerxantares2015-07-21 20:05:01 +0200
commit1c88cd8251daf31f1617f05a5d7273dee345b040 (patch)
treeb76c9dc62dff2ddeed870e3e76b8604b947bac25
downloadaur-1c88cd8251daf31f1617f05a5d7273dee345b040.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..091208f33f3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-libsndfile
+ pkgdesc = A C library for reading and writing files containing sampled sound (mingw-w64)
+ pkgver = 1.0.25
+ pkgrel = 3
+ url = http://www.mega-nerd.com/libsndfile
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-flac
+ depends = mingw-w64-libvorbis
+ depends = mingw-w64-crt
+ depends = mingw-w64-configure
+ options = staticlibs
+ options = !strip
+ source = http://www.mega-nerd.com/libsndfile/files/libsndfile-1.0.25.tar.gz
+ md5sums = e2b7bb637e01022c7d20f95f9c3990a2
+
+pkgname = mingw-w64-libsndfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56b50dbc4331
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: naelstrof <naelstrof@gmail.com>
+
+# This PKGBUILD is on github: https://github.com/naelstrof/aur-pkgbuilds
+
+pkgname=mingw-w64-libsndfile
+pkgver=1.0.25
+pkgrel=3
+pkgdesc="A C library for reading and writing files containing sampled sound (mingw-w64)"
+arch=(any)
+url="http://www.mega-nerd.com/libsndfile"
+license=('LGPL')
+makedepends=('mingw-w64-gcc')
+depends=('mingw-w64-flac' 'mingw-w64-libvorbis' 'mingw-w64-crt' 'mingw-w64-configure')
+options=('staticlibs' '!strip')
+source=(http://www.mega-nerd.com/libsndfile/files/libsndfile-${pkgver}.tar.gz)
+md5sums=('e2b7bb637e01022c7d20f95f9c3990a2')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ unset LDFLAGS CFLAGS CXXFLAGS
+ for _arch in ${_architectures}; do
+ mkdir -p ${srcdir}/libsndfile-${pkgver}/${_arch}
+ cd ${srcdir}/libsndfile-${pkgver}/${_arch}
+ LIBS="`${_arch}-pkg-config --libs vorbis ogg`" ${_arch}-configure
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd ${srcdir}/libsndfile-${pkgver}/${_arch}
+ make DESTDIR="${pkgdir}" install
+ rm -r $pkgdir/usr/${_arch}/share/doc/
+ rm -r $pkgdir/usr/${_arch}/share/man/
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}