summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-08-07 15:27:10 +0200
committerMichel Zou2016-08-07 15:27:10 +0200
commit5eb093b1821dcbdfdea79c18718345b5d687940c (patch)
treebb1b3b90bddc14b2cae44df65de71ec4afd969e6
parent1c88cd8251daf31f1617f05a5d7273dee345b040 (diff)
downloadaur-5eb093b1821dcbdfdea79c18718345b5d687940c.tar.gz
1.0.27
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 091208f33f3d..5dc791af4987 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Aug 7 13:27:10 UTC 2016
pkgbase = mingw-w64-libsndfile
pkgdesc = A C library for reading and writing files containing sampled sound (mingw-w64)
- pkgver = 1.0.25
- pkgrel = 3
+ pkgver = 1.0.27
+ pkgrel = 1
url = http://www.mega-nerd.com/libsndfile
arch = any
license = LGPL
- makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
depends = mingw-w64-flac
depends = mingw-w64-libvorbis
depends = mingw-w64-crt
- depends = mingw-w64-configure
options = staticlibs
options = !strip
- source = http://www.mega-nerd.com/libsndfile/files/libsndfile-1.0.25.tar.gz
- md5sums = e2b7bb637e01022c7d20f95f9c3990a2
+ options = !buildflags
+ source = http://www.mega-nerd.com/libsndfile/files/libsndfile-1.0.27.tar.gz
+ md5sums = fd1d97c6077f03b5d984d7956ffedb7a
pkgname = mingw-w64-libsndfile
diff --git a/PKGBUILD b/PKGBUILD
index 56b50dbc4331..b133c01df596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
-# Maintainer: naelstrof <naelstrof@gmail.com>
-
-# This PKGBUILD is on github: https://github.com/naelstrof/aur-pkgbuilds
+# Contributor: naelstrof <naelstrof@gmail.com>
pkgname=mingw-w64-libsndfile
-pkgver=1.0.25
-pkgrel=3
+pkgver=1.0.27
+pkgrel=1
pkgdesc="A C library for reading and writing files containing sampled sound (mingw-w64)"
arch=(any)
url="http://www.mega-nerd.com/libsndfile"
license=('LGPL')
-makedepends=('mingw-w64-gcc')
-depends=('mingw-w64-flac' 'mingw-w64-libvorbis' 'mingw-w64-crt' 'mingw-w64-configure')
-options=('staticlibs' '!strip')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-flac' 'mingw-w64-libvorbis' 'mingw-w64-crt')
+options=('staticlibs' '!strip' '!buildflags')
source=(http://www.mega-nerd.com/libsndfile/files/libsndfile-${pkgver}.tar.gz)
-md5sums=('e2b7bb637e01022c7d20f95f9c3990a2')
+md5sums=('fd1d97c6077f03b5d984d7956ffedb7a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- unset LDFLAGS CFLAGS CXXFLAGS
+ cd "${srcdir}/libsndfile-${pkgver}"
for _arch in ${_architectures}; do
- mkdir -p ${srcdir}/libsndfile-${pkgver}/${_arch}
- cd ${srcdir}/libsndfile-${pkgver}/${_arch}
- LIBS="`${_arch}-pkg-config --libs vorbis ogg`" ${_arch}-configure
- make
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ LIBS="`${_arch}-pkg-config --libs vorbis ogg`" ${_arch}-configure
+ make
+ popd
done
}
package() {
for _arch in ${_architectures}; do
- cd ${srcdir}/libsndfile-${pkgver}/${_arch}
- make DESTDIR="${pkgdir}" install
- rm -r $pkgdir/usr/${_arch}/share/doc/
- rm -r $pkgdir/usr/${_arch}/share/man/
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ cd ${srcdir}/libsndfile-${pkgver}/build-${_arch}
+ make DESTDIR="${pkgdir}" install
+ rm -r $pkgdir/usr/${_arch}/share/
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}
+