summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2016-03-20 11:12:52 +0100
committerkfg2016-03-20 11:12:52 +0100
commitfe5923e1cdfdb86ccbbaafcd98aaf6b9eecba8a1 (patch)
treedd63d00ce37256d31b3fcd45ca92190800cba107
parenta6c28825aa64e465d94106ca8c49e231910dd038 (diff)
downloadaur-fe5923e1cdfdb86ccbbaafcd98aaf6b9eecba8a1.tar.gz
Added static libs (Contributed by Martchus)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD59
2 files changed, 59 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b207c90464d6..c1cc62ede25f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Mar 20 10:10:18 UTC 2016
pkgbase = mingw-w64-libsoxr
pkgdesc = The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (mingw-w64)
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/p/soxr/wiki/Home/
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index ea92dfb66874..b6b81981bd22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
# Contributor: Anatol Pomozov
# Contributor: JSpaces <jspace -aT- unseen -d0T- is>
# Contributor: Triode <triode1 -aT- btinternet -d0t- com>
+# Contributor: Martchus <martchus@gmx.net>
pkgname=mingw-w64-libsoxr
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='The SoX Resampler library that aims to give fast and high quality results for any constant resampling ratio (mingw-w64)'
-arch=('any')
+arch=('any')
url='http://sourceforge.net/p/soxr/wiki/Home/'
license=(GPL)
depends=(mingw-w64-crt)
@@ -32,6 +33,8 @@ build() {
#FIXME: Tests are disabled for now. The tests are patched to recognize the
# .exe suffix but i'm not sure how to nicely tell cmake to run them with
# wine
+
+ # build shared libs
${_arch}-cmake \
-DBUILD_EXAMPLES=OFF \
-DCMAKE_BUILD_TYPE=Release \
@@ -44,6 +47,24 @@ build() {
-DWITH_SIMD=ON \
-DHAVE_WORDS_BIGENDIAN_EXITCODE=0 \
-DBUILD_TESTS=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ ${srcdir}/soxr-$pkgver-Source
+ make
+
+ # build static libs
+ ${_arch}-cmake \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DVISIBILITY_HIDDENL=ON \
+ -DWITH_AVFFT=ON \
+ -DWITH_DOUBLE_PRECISION=ON \
+ -DWITH_LSR_BINDINGS=ON \
+ -DWITH_OPENMP=ON \
+ -DWITH_PFFFT=ON \
+ -DWITH_SIMD=ON \
+ -DHAVE_WORDS_BIGENDIAN_EXITCODE=0 \
+ -DBUILD_TESTS=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=OFF \
${srcdir}/soxr-$pkgver-Source
make
done
@@ -57,7 +78,39 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}"/build-${_arch}
-
+
+ # install shared libs
+ ${_arch}-cmake \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DVISIBILITY_HIDDENL=ON \
+ -DWITH_AVFFT=ON \
+ -DWITH_DOUBLE_PRECISION=ON \
+ -DWITH_LSR_BINDINGS=ON \
+ -DWITH_OPENMP=ON \
+ -DWITH_PFFFT=ON \
+ -DWITH_SIMD=ON \
+ -DHAVE_WORDS_BIGENDIAN_EXITCODE=0 \
+ -DBUILD_TESTS=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ ${srcdir}/soxr-$pkgver-Source
+ make DESTDIR="$pkgdir" install
+
+ # install static libs
+ ${_arch}-cmake \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DVISIBILITY_HIDDENL=ON \
+ -DWITH_AVFFT=ON \
+ -DWITH_DOUBLE_PRECISION=ON \
+ -DWITH_LSR_BINDINGS=ON \
+ -DWITH_OPENMP=ON \
+ -DWITH_PFFFT=ON \
+ -DWITH_SIMD=ON \
+ -DHAVE_WORDS_BIGENDIAN_EXITCODE=0 \
+ -DBUILD_TESTS=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=OFF \
+ ${srcdir}/soxr-$pkgver-Source
make DESTDIR="$pkgdir" install
${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll