summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2023-11-06 20:52:13 +0100
committerMichel Zou2023-11-06 20:52:13 +0100
commit89b09ff855a5b2f8424789fb8c4d8ffd7a9a72cf (patch)
treeb79731d20c9ad15aa3cc3e166fe6517779e8c697
parent18a73766aa93b23fadd6eaa6802168c7fa4e46f4 (diff)
downloadaur-89b09ff855a5b2f8424789fb8c4d8ffd7a9a72cf.tar.gz
5.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--libspatialite_macros.patch12
-rw-r--r--libspatialite_mingw.patch23
4 files changed, 6 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3da45d6a78d..1b29be848be8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libspatialite
pkgdesc = SQLite extension to support spatial data types and operations (mingw-w64)
- pkgver = 5.0.1
+ pkgver = 5.1.0
pkgrel = 1
url = https://www.gaia-gis.it/fossil/libspatialite
arch = any
@@ -18,12 +18,10 @@ pkgbase = mingw-w64-libspatialite
options = !buildflags
options = staticlibs
options = !strip
- source = https://www.gaia-gis.it/gaia-sins/libspatialite-5.0.1.tar.gz
+ source = https://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-5.1.0.tar.gz
source = libspatialite_geos.patch
source = libspatialite_mingw.patch
- source = libspatialite_macros.patch
- sha256sums = eecbc94311c78012d059ebc0fae86ea5ef6eecb13303e6e82b3753c1b3409e98
- sha256sums = SKIP
+ sha256sums = 43be2dd349daffe016dd1400c5d11285828c22fea35ca5109f21f3ed50605080
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0adc0d16b3d2..52f965d5d223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-libspatialite
-pkgver=5.0.1
+pkgver=5.1.0
pkgrel=1
pkgdesc="SQLite extension to support spatial data types and operations (mingw-w64)"
arch=('any')
@@ -8,17 +8,15 @@ license=('MPL' 'GPL' 'LGPL')
depends=('mingw-w64-geos' 'mingw-w64-libfreexl' 'mingw-w64-librttopo' 'mingw-w64-libxml2' 'mingw-w64-minizip' 'mingw-w64-proj' 'mingw-w64-sqlite')
makedepends=('mingw-w64-configure')
options=('!buildflags' 'staticlibs' '!strip')
-source=(https://www.gaia-gis.it/gaia-sins/libspatialite-$pkgver.tar.gz libspatialite_geos.patch libspatialite_mingw.patch libspatialite_macros.patch)
-sha256sums=('eecbc94311c78012d059ebc0fae86ea5ef6eecb13303e6e82b3753c1b3409e98' SKIP SKIP SKIP)
+source=(https://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-$pkgver.tar.gz libspatialite_geos.patch libspatialite_mingw.patch)
+sha256sums=('43be2dd349daffe016dd1400c5d11285828c22fea35ca5109f21f3ed50605080' SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}"/libspatialite-$pkgver
- #sed -i "s|#include <Windows.h>|#include <windows.h>|g" src/gaiageo/gg_shape.c
patch -p1 -i "${srcdir}"/libspatialite_geos.patch
patch -p1 -i "${srcdir}"/libspatialite_mingw.patch
- patch -p1 -i "${srcdir}"/libspatialite_macros.patch
}
build() {
diff --git a/libspatialite_macros.patch b/libspatialite_macros.patch
deleted file mode 100644
index 9b71ab7658a2..000000000000
--- a/libspatialite_macros.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rupN --no-dereference libspatialite-5.0.1/configure.ac libspatialite-5.0.1-new/configure.ac
---- libspatialite-5.0.1/configure.ac 2021-03-08 08:57:18.748858216 +0100
-+++ libspatialite-5.0.1-new/configure.ac 2021-03-08 08:57:18.751858215 +0100
-@@ -96,7 +96,7 @@ AC_PROG_INSTALL
- AC_PROG_LN_S
- AC_PROG_MAKE_SET
- AC_LIBTOOL_WIN32_DLL
--AC_PROG_LIBTOOL
-+LT_INIT
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
diff --git a/libspatialite_mingw.patch b/libspatialite_mingw.patch
index 47b1d05670c6..652b7902a86f 100644
--- a/libspatialite_mingw.patch
+++ b/libspatialite_mingw.patch
@@ -10,27 +10,4 @@ diff -rupN --no-dereference libspatialite-5.0.1/configure.ac libspatialite-5.0.1
# Checking for Mac OsX
AM_CONDITIONAL([MACOSX], [test "$target_alias" = "macosx"])
# Checking for Android
-diff -rupN --no-dereference libspatialite-5.0.1/src/gaiageo/gg_shape.c libspatialite-5.0.1-new/src/gaiageo/gg_shape.c
---- libspatialite-5.0.1/src/gaiageo/gg_shape.c 2021-02-07 16:53:46.000000000 +0100
-+++ libspatialite-5.0.1-new/src/gaiageo/gg_shape.c 2021-03-08 08:57:18.485858236 +0100
-@@ -58,7 +58,7 @@ the terms of any one of the MPL, the GPL
- #endif
-
- #ifdef _WIN32
--#include <Windows.h>
-+#include <windows.h>
- #endif
-
- #if OMIT_ICONV == 0 /* if ICONV is disabled no SHP support is available */
-diff -rupN --no-dereference libspatialite-5.0.1/test/scandir4win.h libspatialite-5.0.1-new/test/scandir4win.h
---- libspatialite-5.0.1/test/scandir4win.h 2021-02-07 16:53:47.000000000 +0100
-+++ libspatialite-5.0.1-new/test/scandir4win.h 2021-03-08 08:57:18.485858236 +0100
-@@ -11,7 +11,7 @@ even implied
-
- #ifdef _WIN32
-
--#include <Windows.h>
-+#include <windows.h>
- #include <stdio.h>
- #include <sys/types.h>