summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2017-01-13 23:59:59 +0100
committerNicola Murino2017-01-13 23:59:59 +0100
commit7c31a3a5ad58f2e262606f1087d015d61790565e (patch)
tree31471659fcc99a68433aa80ca4e4b5769de8901a
downloadaur-7c31a3a5ad58f2e262606f1087d015d61790565e.tar.gz
Initial version
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch29
-rw-r--r--PKGBUILD44
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ae15b2ecb52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jan 13 22:59:36 UTC 2017
+pkgbase = mingw-w64-libsrtp
+ pkgdesc = Library for SRTP (Secure Realtime Transport Protocol) (mingw-w64)
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = https://github.com/cisco/libsrtp
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = mingw-w64-libsrtp-1.5.4.tar.gz::https://github.com/cisco/libsrtp/archive/v1.5.4.tar.gz
+ source = 0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
+ sha256sums = 56a7b521c25134f48faff26b0b1e3d4378a14986a2d3d7bc6fefb48987304ff0
+ sha256sums = 27c399254f21e3155b1e4e4fb3772e4a6bce85b40eddefafeffaa37c9d2ef222
+
+pkgname = mingw-w64-libsrtp
+
diff --git a/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch b/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
new file mode 100644
index 000000000000..78645e48b223
--- /dev/null
+++ b/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
@@ -0,0 +1,29 @@
+From fa772c2e3d41de4cdd587700f567b5aff59452bb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Wed, 24 Feb 2016 11:23:28 +0200
+Subject: [PATCH] Don't create a symlink if there is no $(SHAREDLIBVERSION)
+
+Otherwise we create a symlink with the same name as the target, which will
+create a symlink pointing to itself.
+---
+ Makefile.in | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index d9b2c4f..c0a67be 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -273,7 +273,9 @@ install:
+ if [ -f libsrtp.$(SHAREDLIBSUFFIX) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(SHAREDLIB_DIR); \
+ cp libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/; \
+- ln -sfn libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp.$(SHAREDLIBSUFFIXNOVER); \
++ if [ -n "$(SHAREDLIBVERSION)" ]; then \
++ ln -sfn libsrtp.$(SHAREDLIBSUFFIX) $(DESTDIR)$(SHAREDLIB_DIR)/libsrtp.$(SHAREDLIBSUFFIXNOVER); \
++ fi; \
+ fi
+ if [ "$(pkgconfig_DATA)" != "" ]; then \
+ $(INSTALL) -d $(DESTDIR)$(pkgconfigdir); \
+--
+2.7.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8b815f26e30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+pkgname=mingw-w64-libsrtp
+pkgver=1.5.4
+pkgrel=1
+pkgdesc="Library for SRTP (Secure Realtime Transport Protocol) (mingw-w64)"
+arch=('any')
+url="https://github.com/cisco/libsrtp"
+license=('BSD')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch")
+sha256sums=('56a7b521c25134f48faff26b0b1e3d4378a14986a2d3d7bc6fefb48987304ff0'
+ '27c399254f21e3155b1e4e4fb3772e4a6bce85b40eddefafeffaa37c9d2ef222')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/libsrtp-${pkgver}"
+ patch -p1 -i ${srcdir}/0001-Don-t-create-a-symlink-if-there-is-no-SHAREDLIBVERSI.patch
+}
+
+build() {
+ export ac_cv_lib_pcap_pcap_create=no
+ cd "${srcdir}/libsrtp-$pkgver/"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ..
+ make all shared_library
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/libsrtp-$pkgver/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+
+# vim: ts=2 sw=2 et: