summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-02-26 14:34:42 +0100
committerMichel Zou2017-02-26 14:34:42 +0100
commit6e31039ab59bb2ad9c5c37c4bed4b1cb04464274 (patch)
tree5219f6e2401a7421fc9317daafeba44efa276e34
parent1b511884414c85c1be13b535f04dabfeb4657c92 (diff)
downloadaur-6e31039ab59bb2ad9c5c37c4bed4b1cb04464274.tar.gz
Rename-gnulib-symbols
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Rename-gnulib-symbols.patch40
-rw-r--r--PKGBUILD20
3 files changed, 58 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c93ff71a0e8a..571db7c60141 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
# Generated by mksrcinfo v8
-# Tue Feb 7 19:04:47 UTC 2017
+# Sun Feb 26 13:34:42 UTC 2017
pkgbase = mingw-w64-libtasn1
pkgdesc = The ASN.1 library used in GNUTLS (mingw-w64)
pkgver = 4.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/libtasn1
arch = any
license = GPL3, LGPL
makedepends = mingw-w64-configure
- makedepends = texinfo
depends = mingw-w64-crt
options = staticlibs
options = !strip
options = !buildflags
source = http://ftp.gnu.org/gnu/libtasn1/libtasn1-4.10.tar.gz
+ source = 0001-Rename-gnulib-symbols.patch
md5sums = f4faffdf63969d0e4e6df43b9679e8e5
+ md5sums = b966fbc667038870bd472b38b086e79f
pkgname = mingw-w64-libtasn1
diff --git a/0001-Rename-gnulib-symbols.patch b/0001-Rename-gnulib-symbols.patch
new file mode 100644
index 000000000000..cd703d3b1fd7
--- /dev/null
+++ b/0001-Rename-gnulib-symbols.patch
@@ -0,0 +1,40 @@
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Fri, 14 Aug 2015 18:40:16 +0200
+Subject: [PATCH] Rename gnulib symbols
+
+---
+ configure.ac | 1 +
+ lib/glm4/strverscmp.m4 | 5 +++++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 551ad3f..d72b1d6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,7 @@ AC_SUBST(LT_AGE, 5)
+ AC_PROG_CC
+ gl_EARLY
+ lgl_EARLY
++AC_DEFINE([hash_pjw_bare], [libtasn_hash_pjw_bare], [Rename hash_pjw_bare])
+ AC_PROG_YACC
+
+ AC_ARG_ENABLE(doc,
+diff --git a/lib/glm4/strverscmp.m4 b/lib/glm4/strverscmp.m4
+index cbcca3f..7a9f2e1 100644
+--- a/lib/glm4/strverscmp.m4
++++ b/lib/glm4/strverscmp.m4
+@@ -14,6 +14,11 @@ AC_DEFUN([gl_FUNC_STRVERSCMP],
+ if test $ac_cv_func_strverscmp = no; then
+ HAVE_STRVERSCMP=0
+ fi
++
++ if test "x$HAVE_STRVERSCMP" == "x0"; then
++ AC_DEFINE([strverscmp], [libtasn_strverscmp], [Rename strverscmp])
++ AC_DEFINE([__strverscmp], [libtasn_strverscmp], [Rename strverscmp])
++ fi
+ ])
+
+ # Prerequisites of lib/strverscmp.c.
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
index ec8bf2106224..e5628f88e5b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
pkgname=mingw-w64-libtasn1
pkgver=4.10
-pkgrel=1
+pkgrel=2
pkgdesc="The ASN.1 library used in GNUTLS (mingw-w64)"
arch=(any)
url="http://www.gnu.org/software/libtasn1"
license=("GPL3, LGPL")
-makedepends=(mingw-w64-configure texinfo)
+makedepends=(mingw-w64-configure)
depends=(mingw-w64-crt)
options=(staticlibs !strip !buildflags)
-source=("http://ftp.gnu.org/gnu/libtasn1/libtasn1-${pkgver}.tar.gz")
-md5sums=('f4faffdf63969d0e4e6df43b9679e8e5')
+source=("http://ftp.gnu.org/gnu/libtasn1/libtasn1-${pkgver}.tar.gz"
+ 0001-Rename-gnulib-symbols.patch)
+md5sums=('f4faffdf63969d0e4e6df43b9679e8e5'
+ 'b966fbc667038870bd472b38b086e79f')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}"/libtasn1-${pkgver}
+ # https://cgit.freedesktop.org/gstreamer/cerbero/tree/recipes/libtasn1/0001-Rename-gnulib-symbols.patch
+ patch -p1 -i "${srcdir}"/0001-Rename-gnulib-symbols.patch
+ autoreconf -vfi
+}
+
build() {
cd "${srcdir}"/libtasn1-${pkgver}
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure
+ ${_arch}-configure --disable-doc
make
popd
done
@@ -27,7 +36,6 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/libtasn1-${pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- rm -r "$pkgdir/usr/${_arch}/share"
rm "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a