summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-04-13 18:23:17 -0700
committerSchala2017-04-13 18:23:17 -0700
commit1848c54ee5487fe70a4a25d8165e34b7fb3eb218 (patch)
tree081402bc7c674f24d3f0c1b316cc701a01da9d9b
parent0c98d40307d245513a8e1b5f22cac5b1dddce587 (diff)
downloadaur-1848c54ee5487fe70a4a25d8165e34b7fb3eb218.tar.gz
Halyfax compatibility patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix-hylafax.patch33
3 files changed, 47 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9bcd4666728..88654029cad1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 11 01:39:18 UTC 2017
+# Fri Apr 14 01:22:55 UTC 2017
pkgbase = mingw-w64-libtiff
pkgdesc = Library for manipulation of TIFF images (mingw-w64)
pkgver = 4.0.7
- pkgrel = 2
+ pkgrel = 3
url = http://www.remotesensing.org/libtiff
arch = any
license = custom
@@ -15,7 +15,9 @@ pkgbase = mingw-w64-libtiff
options = !buildflags
options = !strip
source = http://download.osgeo.org/libtiff/tiff-4.0.7.tar.gz
+ source = fix-hylafax.patch
sha1sums = 2c1b64478e88f93522a42dd5271214a0e5eae648
+ sha1sums = 32166444112dc283ffa4ffdb56c81f246243434c
pkgname = mingw-w64-libtiff
diff --git a/PKGBUILD b/PKGBUILD
index e551fd64a9c9..e741f2a221a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: bubla <matej.tyc@gmail.com>
pkgname=mingw-w64-libtiff
pkgver=4.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
arch=(any)
url="http://www.remotesensing.org/libtiff"
@@ -9,11 +9,18 @@ license=("custom")
depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
-source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
-sha1sums=('2c1b64478e88f93522a42dd5271214a0e5eae648')
+source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz"
+"fix-hylafax.patch")
+sha1sums=('2c1b64478e88f93522a42dd5271214a0e5eae648'
+ '32166444112dc283ffa4ffdb56c81f246243434c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/tiff-${pkgver}"
+ patch -Nbp1 -i ${srcdir}/fix-hylafax.patch
+}
+
build() {
export CFLAGS+=" -fno-strict-aliasing"
export CXXFLAGS+=" -fno-strict-aliasing"
diff --git a/fix-hylafax.patch b/fix-hylafax.patch
new file mode 100644
index 000000000000..635b6aef3d7c
--- /dev/null
+++ b/fix-hylafax.patch
@@ -0,0 +1,33 @@
+From 7757b91a71631ada835740733f3dab51eda36df8 Mon Sep 17 00:00:00 2001
+From: erouault <erouault>
+Date: Tue, 13 Dec 2016 18:15:48 +0000
+Subject: [PATCH] * libtiff/tif_fax3.h: revert change done on 2016-01-09 that
+ made Param member of TIFFFaxTabEnt structure a uint16 to reduce size of the
+ binary. It happens that the Hylafax software uses the tables that follow this
+ typedef (TIFFFaxMainTable, TIFFFaxWhiteTable, TIFFFaxBlackTable), also they
+ are not in a public libtiff header. Raised by Lee Howard. Fixes
+ http://bugzilla.maptools.org/show_bug.cgi?id=2636
+
+---
+ ChangeLog | 10 ++++++++++
+ libtiff/tif_fax3.h | 4 +++-
+ 2 files changed, 13 insertions(+), 1 deletion(-)
+
+diff --git a/libtiff/tif_fax3.h b/libtiff/tif_fax3.h
+index aafb5a7..2b64290 100644
+--- a/libtiff/tif_fax3.h
++++ b/libtiff/tif_fax3.h
+@@ -81,10 +81,12 @@ extern void _TIFFFax3fillruns(unsigned char*, uint32*, uint32*, uint32);
+ #define S_MakeUp 11
+ #define S_EOL 12
+
++/* WARNING: do not change the layout of this structure as the Halyfax software */
++/* really depends on it. See http://bugzilla.maptools.org/show_bug.cgi?id=2636 */
+ typedef struct { /* state table entry */
+ unsigned char State; /* see above */
+ unsigned char Width; /* width of code in bits */
+- uint16 Param; /* unsigned 16-bit run length in bits */
++ uint32 Param; /* unsigned 32-bit run length in bits (holds on 16 bit actually, but cannot be changed. See above warning) */
+ } TIFFFaxTabEnt;
+
+ extern const TIFFFaxTabEnt TIFFFaxMainTable[];