summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-08-18 23:50:45 -0700
committerSchala2016-08-18 23:50:45 -0700
commit28b91b83e9d3553c924b896edee01af1fd3680a9 (patch)
tree62e1730bb79c093bc60832d33d0d83548a2052e2
parent979791d54277798f1ee4c129157af1869db156ec (diff)
downloadaur-28b91b83e9d3553c924b896edee01af1fd3680a9.tar.gz
keep EXEs
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79c0029549c6..c43e2c738ea9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Aug 19 06:50:28 UTC 2016
pkgbase = mingw-w64-libtiff
pkgdesc = Library for manipulation of TIFF images (mingw-w64)
pkgver = 4.0.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.remotesensing.org/libtiff
arch = any
license = custom
@@ -9,6 +11,7 @@ pkgbase = mingw-w64-libtiff
depends = mingw-w64-libjpeg-turbo
depends = mingw-w64-zlib
depends = mingw-w64-xz
+ depends = libtiff
options = staticlibs
options = !buildflags
options = !strip
diff --git a/.gitignore b/.gitignore
index 25cca9a92b37..5b06d8419137 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.gz
+*.tar
*.xz
diff --git a/PKGBUILD b/PKGBUILD
index 5d08e5bc7dc8..b394e1f9262d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Contributor: bubla <matej.tyc@gmail.com>
pkgname=mingw-w64-libtiff
pkgver=4.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
arch=(any)
url="http://www.remotesensing.org/libtiff"
license=("custom")
-depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
+depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz libtiff)
makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
@@ -34,9 +34,9 @@ package() {
make DESTDIR="${pkgdir}" install
cp "${srcdir}/tiff-${pkgver}/libtiff/"{tiffiop,tif_dir}.h "${pkgdir}/usr/${_arch}/include/"
cp libtiff/tif_config.h "${pkgdir}/usr/${_arch}/include/"
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm -r "$pkgdir/usr/${_arch}/share"
+ #rm -r "$pkgdir/usr/${_arch}/share"
done
}