summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpingplug2018-11-17 16:53:06 +0800
committerpingplug2018-11-17 16:53:06 +0800
commit452adc4aa6dd22e1073f299a3c31f9529e55dbf1 (patch)
tree6bd196ede2064d81d6cf975c5b0b4640d4c2c32f
parent9d2b3a20ad0d376175ca6aea2f8c48d1a91cb132 (diff)
downloadaur-452adc4aa6dd22e1073f299a3c31f9529e55dbf1.tar.gz
Updated to 4.0.10
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD47
3 files changed, 36 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b482fd8da843..f22931125d53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libtiff
pkgdesc = Library for manipulation of TIFF images (mingw-w64)
- pkgver = 4.0.9
+ pkgver = 4.0.10
pkgrel = 1
url = http://www.simplesystems.org/libtiff/
arch = any
@@ -9,11 +9,11 @@ pkgbase = mingw-w64-libtiff
depends = mingw-w64-libjpeg-turbo
depends = mingw-w64-zlib
depends = mingw-w64-xz
+ options = !strip
options = staticlibs
options = !buildflags
- options = !strip
- source = http://download.osgeo.org/libtiff/tiff-4.0.9.tar.gz
- sha256sums = 6e7bdeec2c310734e734d19aae3a71ebe37a4d842e0e23dbb1b8921c0026cfcd
+ source = http://download.osgeo.org/libtiff/tiff-4.0.10.tar.gz
+ sha256sums = 2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4
pkgname = mingw-w64-libtiff
diff --git a/.gitignore b/.gitignore
index 49c4674d6625..97589fb4de69 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,7 @@
-pkg/
-src/
-*.gz
-*.log
-*.tar
-*.xz
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.install
+!*.patch
+!*.diff
diff --git a/PKGBUILD b/PKGBUILD
index c8f4e8fd21db..13e281bd3948 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
# Contributor: bubla <matej.tyc@gmail.com>
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-libtiff
-pkgver=4.0.9
+pkgver=4.0.10
pkgrel=1
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
-arch=(any)
+arch=('any')
url="http://www.simplesystems.org/libtiff/"
-license=("custom")
-depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
-makedepends=(mingw-w64-configure)
-options=(staticlibs !buildflags !strip)
+license=('custom')
+depends=('mingw-w64-libjpeg-turbo'
+ 'mingw-w64-zlib'
+ 'mingw-w64-xz')
+makedepends=('mingw-w64-configure')
+options=('!strip' 'staticlibs' '!buildflags')
source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
-sha256sums=('6e7bdeec2c310734e734d19aae3a71ebe37a4d842e0e23dbb1b8921c0026cfcd')
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
-prepare() {
- cd tiff-$pkgver
-}
+sha256sums=('2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4')
build() {
- export CFLAGS+=" -fno-strict-aliasing"
- export CXXFLAGS+=" -fno-strict-aliasing"
+ export CFLAGS="-fno-strict-aliasing"
+ export CXXFLAGS="-fno-strict-aliasing"
cd "${srcdir}/tiff-${pkgver}"
- for _arch in ${_architectures}; do
+ for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
- --disable-jbig \
- --without-x
+ --disable-jbig \
+ --without-x
make
popd
done
@@ -37,9 +38,11 @@ package() {
cd "${srcdir}/tiff-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
cp "${srcdir}/tiff-${pkgver}/libtiff/"{tiffiop,tif_dir}.h "${pkgdir}/usr/${_arch}/include/"
- cp libtiff/tif_config.h "${pkgdir}/usr/${_arch}/include/"
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ cp libtiff/tif_config.h "${pkgdir}/usr/${_arch}/include/"
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}
+
+# vim:set ts=2 sw=2 et: