summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-11-04 13:06:47 -0800
committerBuildTools2015-11-04 13:06:47 -0800
commit979791d54277798f1ee4c129157af1869db156ec (patch)
treec53c9ffd0a6a291148e91e86739c298870b6d552
parent436636af9e76756d6972e07d968dfe5605a90e14 (diff)
downloadaur-979791d54277798f1ee4c129157af1869db156ec.tar.gz
4.0.6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d85f99ac07a..79c0029549c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libtiff
pkgdesc = Library for manipulation of TIFF images (mingw-w64)
- pkgver = 4.0.4
+ pkgver = 4.0.6
pkgrel = 1
url = http://www.remotesensing.org/libtiff
arch = any
@@ -8,11 +8,12 @@ pkgbase = mingw-w64-libtiff
makedepends = mingw-w64-configure
depends = mingw-w64-libjpeg-turbo
depends = mingw-w64-zlib
+ depends = mingw-w64-xz
options = staticlibs
options = !buildflags
options = !strip
- source = http://download.osgeo.org/libtiff/tiff-4.0.4.tar.gz
- sha1sums = 185f844babe4ee902b5e4775d9f65915fcbabd11
+ source = http://download.osgeo.org/libtiff/tiff-4.0.6.tar.gz
+ sha1sums = 280e27704eaca5f592b82e71ac0c78b87395e2de
pkgname = mingw-w64-libtiff
diff --git a/PKGBUILD b/PKGBUILD
index 21a0322fab13..5d08e5bc7dc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
# Contributor: bubla <matej.tyc@gmail.com>
pkgname=mingw-w64-libtiff
-pkgver=4.0.4
+pkgver=4.0.6
pkgrel=1
pkgdesc="Library for manipulation of TIFF images (mingw-w64)"
arch=(any)
url="http://www.remotesensing.org/libtiff"
license=("custom")
-depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib)
+depends=(mingw-w64-libjpeg-turbo mingw-w64-zlib mingw-w64-xz)
makedepends=(mingw-w64-configure)
options=(staticlibs !buildflags !strip)
source=("http://download.osgeo.org/libtiff/tiff-${pkgver}.tar.gz")
-sha1sums=('185f844babe4ee902b5e4775d9f65915fcbabd11')
+sha1sums=('280e27704eaca5f592b82e71ac0c78b87395e2de')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
+ export CFLAGS+=" -fno-strict-aliasing"
+ export CXXFLAGS+=" -fno-strict-aliasing"
cd "${srcdir}/tiff-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure
+ ${_arch}-configure \
+ --disable-jbig \
+ --without-x
make
popd
done
@@ -28,6 +32,8 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/tiff-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
+ cp "${srcdir}/tiff-${pkgver}/libtiff/"{tiffiop,tif_dir}.h "${pkgdir}/usr/${_arch}/include/"
+ cp libtiff/tif_config.h "${pkgdir}/usr/${_arch}/include/"
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g