summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-08-07 18:11:43 -0400
committerAndrew Sun2018-08-07 18:11:43 -0400
commit8013888f3496e6e4070847ab7506eafb784ac2da (patch)
treef5b827242e27ad8778ff14ec724041fa6b2a9b34
downloadaur-8013888f3496e6e4070847ab7506eafb784ac2da.tar.gz
add mingw-w64-libuv (version 1.22.0)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc64b5840236
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mingw-w64-libuv
+ pkgdesc = Multi-platform support library with a focus on asynchronous I/O (mingw-w64)
+ pkgver = 1.22.0
+ pkgrel = 1
+ url = https://github.com/libuv/libuv
+ arch = any
+ license = custom
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://github.com/libuv/libuv/archive/v1.22.0/libuv-1.22.0.tar.gz
+ sha512sums = e79cae6aa1d9cf2c8f7c0262c866fea2858d7104ece7c556e537e7d1cf884f191d5cd3e56539bfe857fa15dc50b57fdcb33019824cd585a2ca250a77d923af73
+
+pkgname = mingw-w64-libuv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e41ed002df80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+
+pkgname=mingw-w64-libuv
+_pkgname=libuv
+pkgver=1.22.0
+pkgrel=1
+pkgdesc="Multi-platform support library with a focus on asynchronous I/O (mingw-w64)"
+arch=('any')
+url="https://github.com/libuv/libuv"
+license=('custom')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://github.com/libuv/libuv/archive/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('e79cae6aa1d9cf2c8f7c0262c866fea2858d7104ece7c556e537e7d1cf884f191d5cd3e56539bfe857fa15dc50b57fdcb33019824cd585a2ca250a77d923af73')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}