summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2017-01-16 22:55:20 +0100
committerNicola Murino2017-01-16 22:55:20 +0100
commiteaa2439ae3ae4791a93b458ec236fadc12c1124d (patch)
treee2b2e6620f6dfa1364892becc47c8876832d99b9
downloadaur-eaa2439ae3ae4791a93b458ec236fadc12c1124d.tar.gz
Initial version
-rw-r--r--.SRCINFO39
-rw-r--r--0003-Add-long-long-check-for-win64.patch43
-rw-r--r--0005-Fix-compilation-in-win64.patch28
-rw-r--r--0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch27
-rw-r--r--0010-Only-define-inline-and-friends-if-they-re-not-define.patch51
-rw-r--r--0011-Fix-autoreconf-when-using-our-gettext-version.patch25
-rw-r--r--0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch25
-rw-r--r--0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch24
-rw-r--r--0014-Add-forward-declaration-of-visual_transform_init-as-.patch26
-rw-r--r--0015-Include-lv_cpu.h-in-another-place-too.patch24
-rw-r--r--0016-configure.ac-Use-gettext-0.19.patch25
-rw-r--r--PKGBUILD74
12 files changed, 411 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1ef69041009
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+# Generated by mksrcinfo v8
+# Mon Jan 16 21:55:00 UTC 2017
+pkgbase = mingw-w64-libvisual
+ pkgdesc = Abstraction library that comes between applications and audio visualisation plugins (mingw-w64)
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/libvisual/
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-0.4.0.tar.gz
+ source = 0003-Add-long-long-check-for-win64.patch
+ source = 0005-Fix-compilation-in-win64.patch
+ source = 0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch
+ source = 0010-Only-define-inline-and-friends-if-they-re-not-define.patch
+ source = 0011-Fix-autoreconf-when-using-our-gettext-version.patch
+ source = 0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch
+ source = 0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch
+ source = 0014-Add-forward-declaration-of-visual_transform_init-as-.patch
+ source = 0015-Include-lv_cpu.h-in-another-place-too.patch
+ source = 0016-configure.ac-Use-gettext-0.19.patch
+ sha256sums = 0b4dfdb87125e129567752089e3c8b54cefed601eef169d2533d8659da8dc1d7
+ sha256sums = ad26dc477e09e1cdc28a29e4d1bc7d45ae3db7741d38a1bd56bccfef96bcefaa
+ sha256sums = f5e3eb5e7b2993618be9ac034ac7ac943fb68d3db1cde05f60f406b22666a8b6
+ sha256sums = 4c8ec4b57fe6d795c822587657f7cf82db33013910f27e8df473138b86b3c183
+ sha256sums = f23b4a631bf54fe6479d00d30215519846b2e57563d46d158d3f7bf406105d08
+ sha256sums = 7bc8057ad0c45bf89544f65e5a4eda01b6047552282701f74574be86dad593a5
+ sha256sums = 628e473f90520c57d4ba1b5ff1703ea7cd8bba712c2f15f166e1316dbfd2d8c5
+ sha256sums = 8aac578ffa19f564aa7f29d19ff0441bb7118df74932c37ff23d48b98dfdd7ba
+ sha256sums = 3714354e1702b0356b8a28b72008031d3dd1f0e1aadea1eddaae484338050892
+ sha256sums = aba48dff1437893aca111cb48e1a1043205fe5768d341e587e3a65d3d8d5082d
+ sha256sums = 1607465d32962af516e815295d5c0800745b369b41a767e92e134cf0488c52f1
+
+pkgname = mingw-w64-libvisual
+
diff --git a/0003-Add-long-long-check-for-win64.patch b/0003-Add-long-long-check-for-win64.patch
new file mode 100644
index 000000000000..c5b914063aba
--- /dev/null
+++ b/0003-Add-long-long-check-for-win64.patch
@@ -0,0 +1,43 @@
+From 328509681f4a506b830f0de032d788c68e2ee685 Mon Sep 17 00:00:00 2001
+From: Andoni Morales Alastruey <ylatuya@gmail.com>
+Date: Tue, 6 Mar 2012 17:36:59 +0100
+Subject: [PATCH 03/16] Add long long check for win64
+
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index cd944f8..e21483a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -330,6 +330,7 @@ AC_SUBST(LV_THREAD_CFLAGS)
+ AC_CHECK_SIZEOF(short)
+ AC_CHECK_SIZEOF(int)
+ AC_CHECK_SIZEOF(long)
++AC_CHECK_SIZEOF(long long)
+ AC_CHECK_SIZEOF(size_t)
+
+ dnl Try to figure out whether visual_size should be long or int
+@@ -345,6 +346,9 @@ $ac_cv_sizeof_int)
+ $ac_cv_sizeof_long)
+ visual_size_type=long
+ ;;
++$ac_cv_sizeof_long_long)
++ visual_size_type='long long'
++ ;;
+ *) AC_MSG_ERROR([No type matching size_t in size])
+ ;;
+ esac
+@@ -801,7 +805,7 @@ echo >>$outfile
+ lv_have_threads=$have_threads
+ lv_enable_threads=$enable_threads
+
+-case $visual_size_type in
++case "$visual_size_type" in
+ short)
+ visual_size_format='"hu"'
+ ;;
+--
+2.1.4
+
diff --git a/0005-Fix-compilation-in-win64.patch b/0005-Fix-compilation-in-win64.patch
new file mode 100644
index 000000000000..9f0076dd4cc5
--- /dev/null
+++ b/0005-Fix-compilation-in-win64.patch
@@ -0,0 +1,28 @@
+From c801963c33c8e0af15a00f8a733aa83cf9eca297 Mon Sep 17 00:00:00 2001
+From: Andoni Morales Alastruey <ylatuya@gmail.com>
+Date: Tue, 6 Mar 2012 23:53:38 +0100
+Subject: [PATCH 05/16] Fix compilation in win64
+
+---
+ libvisual/lv_cpu.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/libvisual/lv_cpu.c b/libvisual/lv_cpu.c
+index 867bcf2..fe09752 100644
+--- a/libvisual/lv_cpu.c
++++ b/libvisual/lv_cpu.c
+@@ -115,7 +115,11 @@ static void sigfpe_handler_sse( int signal, struct sigcontext sc )
+ LONG CALLBACK win32_sig_handler_sse(EXCEPTION_POINTERS* ep)
+ {
+ if(ep->ExceptionRecord->ExceptionCode==EXCEPTION_ILLEGAL_INSTRUCTION){
++#ifdef _WIN64
++ ep->ContextRecord->Rip +=3;
++#else
+ ep->ContextRecord->Eip +=3;
++#endif
+ __lv_cpu_caps.hasSSE=0;
+ return EXCEPTION_CONTINUE_EXECUTION;
+ }
+--
+2.1.4
+
diff --git a/0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch b/0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch
new file mode 100644
index 000000000000..adba57b8a12d
--- /dev/null
+++ b/0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch
@@ -0,0 +1,27 @@
+From f4e61c5b501a108384506559a9efd7cd982d863f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian.droege@collabora.co.uk>
+Date: Wed, 22 Aug 2012 16:07:39 +0200
+Subject: [PATCH 08/16] Remove malloc/realloc configure checks, they're broken
+
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e21483a..9550558 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -139,8 +139,8 @@ AC_MSG_RESULT($lv_have_gnuc_varargs)
+ AC_C_BIGENDIAN(bigendian=yes, bigendian=no, )
+
+ # Checks for library functions.
+-AC_FUNC_MALLOC
+-AC_FUNC_REALLOC
++# AC_FUNC_MALLOC
++# AC_FUNC_REALLOC
+ AC_FUNC_SELECT_ARGTYPES
+ AC_CHECK_FUNCS([gettimeofday usleep nanosleep select memset sqrt strdup strndup sysconf sched_setscheduler])
+
+--
+2.1.4
+
diff --git a/0010-Only-define-inline-and-friends-if-they-re-not-define.patch b/0010-Only-define-inline-and-friends-if-they-re-not-define.patch
new file mode 100644
index 000000000000..3adfd99a9859
--- /dev/null
+++ b/0010-Only-define-inline-and-friends-if-they-re-not-define.patch
@@ -0,0 +1,51 @@
+From 3115b039b3c334f7a7ef97c582c4cf22a65ddd35 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian.droege@collabora.co.uk>
+Date: Sat, 2 Mar 2013 19:27:19 +0100
+Subject: [PATCH 10/16] Only #define inline and friends if they're not defined
+ yet
+
+---
+ libvisual/lv_defines.h | 24 ++++++++++++++++++------
+ 1 file changed, 18 insertions(+), 6 deletions(-)
+
+diff --git a/libvisual/lv_defines.h b/libvisual/lv_defines.h
+index adf10fb..3cd104e 100644
+--- a/libvisual/lv_defines.h
++++ b/libvisual/lv_defines.h
+@@ -63,15 +63,27 @@
+
+ /* Compiler specific optimalization macros */
+ #if __GNUC__ >= 3
+-# define inline inline __attribute__ ((always_inline))
+-# define __malloc __attribute__ ((malloc))
+-# define __packed __attribute__ ((packed))
++# ifndef inline
++# define inline inline __attribute__ ((always_inline))
++#endif
++# ifndef __malloc
++# define __malloc __attribute__ ((malloc))
++# endif
++# ifndef __packed
++# define __packed __attribute__ ((packed))
++# endif
+ # define VIS_LIKELY(x) __builtin_expect (!!(x), 1)
+ # define VIS_UNLIKELY(x) __builtin_expect (!!(x), 0)
+ #else
+-# define inline /* no inline */
+-# define __malloc /* no malloc */
+-# define __packed /* no packed */
++# ifndef inline
++# define inline /* no inline */
++# endif
++# ifndef __malloc
++# define __malloc /* no malloc */
++# endif
++# ifndef __packed
++# define __packed /* no packed */
++# endif
+ # define VIS_LIKELY(x) (x)
+ # define VIS_UNLIKELY(x) (x)
+ #endif
+--
+2.1.4
+
diff --git a/0011-Fix-autoreconf-when-using-our-gettext-version.patch b/0011-Fix-autoreconf-when-using-our-gettext-version.patch
new file mode 100644
index 000000000000..4bc82b5b1c40
--- /dev/null
+++ b/0011-Fix-autoreconf-when-using-our-gettext-version.patch
@@ -0,0 +1,25 @@
+From f376afee5ec28b9cc7bfbcd2bc2eb01fda706470 Mon Sep 17 00:00:00 2001
+From: Andoni Morales Alastruey <ylatuya@gmail.com>
+Date: Fri, 22 Mar 2013 17:04:13 +0100
+Subject: [PATCH 11/16] Fix autoreconf when using our gettext version
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9550558..843ef9f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,7 +155,7 @@ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [GETTEXT package name])
+ AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/share/locale", [String catalog location])
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.14.1])
++AM_GNU_GETTEXT_VERSION([0.18.2])
+
+ dnl -------------------------------
+ dnl Check for native thread support
+--
+2.1.4
+
diff --git a/0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch b/0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch
new file mode 100644
index 000000000000..d00775c5fb1a
--- /dev/null
+++ b/0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch
@@ -0,0 +1,25 @@
+From 6237d4dddc5d9998d025ddf019a09c4bcd4fa217 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian.droege@collabora.co.uk>
+Date: Mon, 8 Apr 2013 11:55:55 +0200
+Subject: [PATCH 12/16] configure: gettext 0.18 is enough, no 0.18.2 needed
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 843ef9f..e89815f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,7 +155,7 @@ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [GETTEXT package name])
+ AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/share/locale", [String catalog location])
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.18.2])
++AM_GNU_GETTEXT_VERSION([0.18])
+
+ dnl -------------------------------
+ dnl Check for native thread support
+--
+2.1.4
+
diff --git a/0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch b/0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch
new file mode 100644
index 000000000000..38dfb12940cb
--- /dev/null
+++ b/0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch
@@ -0,0 +1,24 @@
+From cbb1056dc4ea4f606556e472dc78ddb09dbf3218 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Mon, 22 Sep 2014 10:59:08 +0300
+Subject: [PATCH 13/16] Include lv_cpu.h for visual_cpu_initialize()
+
+---
+ libvisual/lv_libvisual.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libvisual/lv_libvisual.c b/libvisual/lv_libvisual.c
+index 8de03eb..5d77486 100644
+--- a/libvisual/lv_libvisual.c
++++ b/libvisual/lv_libvisual.c
+@@ -39,6 +39,7 @@
+ #include "lv_log.h"
+ #include "lv_param.h"
+ #include "lv_thread.h"
++#include "lv_cpu.h"
+ #include "config.h"
+
+
+--
+2.1.4
+
diff --git a/0014-Add-forward-declaration-of-visual_transform_init-as-.patch b/0014-Add-forward-declaration-of-visual_transform_init-as-.patch
new file mode 100644
index 000000000000..56246d2e7d0f
--- /dev/null
+++ b/0014-Add-forward-declaration-of-visual_transform_init-as-.patch
@@ -0,0 +1,26 @@
+From a43b6f7746ab2ef4e4ce5160ebaaccc9c082456e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Mon, 22 Sep 2014 11:01:36 +0300
+Subject: [PATCH 14/16] Add forward declaration of visual_transform_init() as
+ required
+
+---
+ libvisual/lv_transform.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/libvisual/lv_transform.c b/libvisual/lv_transform.c
+index c763768..1ffe03a 100644
+--- a/libvisual/lv_transform.c
++++ b/libvisual/lv_transform.c
+@@ -41,6 +41,8 @@ static int transform_dtor (VisObject *object);
+
+ static VisTransformPlugin *get_transform_plugin (VisTransform *transform);
+
++int visual_transform_init (VisTransform *transform, const char *transformname);
++
+
+ static int transform_dtor (VisObject *object)
+ {
+--
+2.1.4
+
diff --git a/0015-Include-lv_cpu.h-in-another-place-too.patch b/0015-Include-lv_cpu.h-in-another-place-too.patch
new file mode 100644
index 000000000000..9c7d04aee251
--- /dev/null
+++ b/0015-Include-lv_cpu.h-in-another-place-too.patch
@@ -0,0 +1,24 @@
+From 29d92e9733db27d2b4143c27c7ff43bba9f67d39 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Sebastian=20Dr=C3=B6ge?= <sebastian@centricular.com>
+Date: Mon, 22 Sep 2014 11:02:06 +0300
+Subject: [PATCH 15/16] Include lv_cpu.h in another place too
+
+---
+ libvisual/lv_math.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libvisual/lv_math.c b/libvisual/lv_math.c
+index cfae316..da15b74 100644
+--- a/libvisual/lv_math.c
++++ b/libvisual/lv_math.c
+@@ -30,6 +30,7 @@
+
+ #include "lv_bits.h"
+ #include "lv_math.h"
++#include "lv_cpu.h"
+
+ /* This file is getting big and bloated because of the large chunks of simd code. When all is in place we'll take a serious
+ * look how we can reduce this. For example by using macros for common blocks. */
+--
+2.1.4
+
diff --git a/0016-configure.ac-Use-gettext-0.19.patch b/0016-configure.ac-Use-gettext-0.19.patch
new file mode 100644
index 000000000000..18d2f1e5dbe7
--- /dev/null
+++ b/0016-configure.ac-Use-gettext-0.19.patch
@@ -0,0 +1,25 @@
+From cd15f0482252ae3568e106bf15e6bc95aa46fb1c Mon Sep 17 00:00:00 2001
+From: Edward Hervey <bilboed@bilboed.com>
+Date: Fri, 13 Feb 2015 12:49:31 +0100
+Subject: [PATCH 16/16] configure.ac: Use gettext 0.19
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index e89815f..f8a1e9d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -155,7 +155,7 @@ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [GETTEXT package name])
+ AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/share/locale", [String catalog location])
+ AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION([0.18])
++AM_GNU_GETTEXT_VERSION([0.19])
+
+ dnl -------------------------------
+ dnl Check for native thread support
+--
+2.1.4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6984211c876
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+pkgname=mingw-w64-libvisual
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Abstraction library that comes between applications and audio visualisation plugins (mingw-w64)"
+arch=('any')
+url="http://sourceforge.net/projects/libvisual/"
+license=('LGPL')
+makedepends=('mingw-w64-configure')
+depends=('mingw-w64-crt')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("http://downloads.sourceforge.net/sourceforge/libvisual/libvisual-${pkgver}.tar.gz"
+ "0003-Add-long-long-check-for-win64.patch"
+ "0005-Fix-compilation-in-win64.patch"
+ "0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch"
+ "0010-Only-define-inline-and-friends-if-they-re-not-define.patch"
+ "0011-Fix-autoreconf-when-using-our-gettext-version.patch"
+ "0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch"
+ "0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch"
+ "0014-Add-forward-declaration-of-visual_transform_init-as-.patch"
+ "0015-Include-lv_cpu.h-in-another-place-too.patch"
+ "0016-configure.ac-Use-gettext-0.19.patch")
+sha256sums=('0b4dfdb87125e129567752089e3c8b54cefed601eef169d2533d8659da8dc1d7'
+ 'ad26dc477e09e1cdc28a29e4d1bc7d45ae3db7741d38a1bd56bccfef96bcefaa'
+ 'f5e3eb5e7b2993618be9ac034ac7ac943fb68d3db1cde05f60f406b22666a8b6'
+ '4c8ec4b57fe6d795c822587657f7cf82db33013910f27e8df473138b86b3c183'
+ 'f23b4a631bf54fe6479d00d30215519846b2e57563d46d158d3f7bf406105d08'
+ '7bc8057ad0c45bf89544f65e5a4eda01b6047552282701f74574be86dad593a5'
+ '628e473f90520c57d4ba1b5ff1703ea7cd8bba712c2f15f166e1316dbfd2d8c5'
+ '8aac578ffa19f564aa7f29d19ff0441bb7118df74932c37ff23d48b98dfdd7ba'
+ '3714354e1702b0356b8a28b72008031d3dd1f0e1aadea1eddaae484338050892'
+ 'aba48dff1437893aca111cb48e1a1043205fe5768d341e587e3a65d3d8d5082d'
+ '1607465d32962af516e815295d5c0800745b369b41a767e92e134cf0488c52f1')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "libvisual-$pkgver"
+ patch -Np1 -i "$srcdir/0003-Add-long-long-check-for-win64.patch"
+ patch -Np1 -i "$srcdir/0005-Fix-compilation-in-win64.patch"
+ patch -Np1 -i "$srcdir/0008-Remove-malloc-realloc-configure-checks-they-re-broke.patch"
+ patch -Np1 -i "$srcdir/0010-Only-define-inline-and-friends-if-they-re-not-define.patch"
+ patch -Np1 -i "$srcdir/0011-Fix-autoreconf-when-using-our-gettext-version.patch"
+ patch -Np1 -i "$srcdir/0012-configure-gettext-0.18-is-enough-no-0.18.2-needed.patch"
+ patch -Np1 -i "$srcdir/0013-Include-lv_cpu.h-for-visual_cpu_initialize.patch"
+ patch -Np1 -i "$srcdir/0014-Add-forward-declaration-of-visual_transform_init-as-.patch"
+ patch -Np1 -i "$srcdir/0015-Include-lv_cpu.h-in-another-place-too.patch"
+ patch -Np1 -i "$srcdir/0016-configure.ac-Use-gettext-0.19.patch"
+ autoreconf -f -i
+}
+
+
+build() {
+ for _arch in ${_architectures}; do
+ [[ -d "build-${_arch}" ]] && rm -rf "build-${_arch}"
+ cp -rf "$srcdir/libvisual-${pkgver}" "${srcdir}/build-${_arch}"
+ pushd build-${_arch}
+ ${_arch}-configure .
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/build-${_arch}"
+ make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir"/usr/${_arch}/share/locale
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+
+# vim: ts=2 sw=2 et: