summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2017-04-14 11:59:50 +0200
committerkfg2017-04-14 12:15:05 +0200
commit5eb12b8ab87c7a294a24c6a1607909f05dc546dd (patch)
tree8cf835c529f342dbc6bc2a2ead7d2b7d32b10405
parentb5f39d4c7b3361a6dcbcc1003fcfa59bc022a1a8 (diff)
downloadaur-5eb12b8ab87c7a294a24c6a1607909f05dc546dd.tar.gz
keep EXEs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--configure.patch44
3 files changed, 34 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9fa982f68028..4f14f7c6f66e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jan 25 19:57:51 UTC 2017
+# Fri Apr 14 10:14:43 UTC 2017
pkgbase = mingw-w64-libvpx
pkgdesc = VP8 and VP9 codec (mingw-w64)
pkgver = 1.6.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.webmproject.org/
arch = any
license = BSD
@@ -17,7 +17,7 @@ pkgbase = mingw-w64-libvpx
source = libvpx-1.6.1.tar.gz::https://github.com/webmproject/libvpx/archive/v1.6.1.tar.gz
source = configure.patch
sha256sums = cda8bb6f0e4848c018177d3a576fa83ed96d762554d7010fe4cfb9d70c22e588
- sha256sums = 73ffee7c361682e6483b2209b2a55887c29c23174b994229bbe0642e09214093
+ sha256sums = c904d945fe6f59d981bb6f7650be90a59b5b5704b31dfa385d3e99eb63d98086
pkgname = mingw-w64-libvpx
diff --git a/PKGBUILD b/PKGBUILD
index 55e30929c1b6..f0b58f11798d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-libvpx
pkgver=1.6.1
-pkgrel=2
+pkgrel=3
pkgdesc="VP8 and VP9 codec (mingw-w64)"
arch=('any')
url="http://www.webmproject.org/"
@@ -12,7 +12,7 @@ makedepends=('mingw-w64-gcc' 'yasm' 'git')
source=(libvpx-$pkgver.tar.gz::https://github.com/webmproject/libvpx/archive/v$pkgver.tar.gz
'configure.patch')
sha256sums=('cda8bb6f0e4848c018177d3a576fa83ed96d762554d7010fe4cfb9d70c22e588'
- '73ffee7c361682e6483b2209b2a55887c29c23174b994229bbe0642e09214093')
+ 'c904d945fe6f59d981bb6f7650be90a59b5b5704b31dfa385d3e99eb63d98086')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
@@ -40,9 +40,7 @@ build() {
--enable-runtime-cpu-detect \
--enable-shared \
--enable-pic \
- --disable-examples \
--disable-docs \
- --disable-install-bins \
--disable-install-docs \
--disable-install-srcs \
--enable-vp8 \
@@ -62,13 +60,13 @@ package() {
make DIST_DIR="$pkgdir/usr/${_arch}" install
#Move the hacked in shared libs to bin
- mkdir ${pkgdir}/usr/${_arch}/bin
mv ${pkgdir}/usr/${_arch}/lib/libvpx.dll ${pkgdir}/usr/${_arch}/bin/
mv ${pkgdir}/usr/${_arch}/lib/libvpx.dll.4* ${pkgdir}/usr/${_arch}/bin/
#Install implib
install -m 0644 ${srcdir}/libvpx-$pkgver/build-${_arch}/libvpx.dll.a ${pkgdir}/usr/${_arch}/lib/libvpx.dll.a
+ ${_arch}-strip -s ${pkgdir}/usr/${_arch}/bin/*.exe
${_arch}-strip -g --strip-unneeded ${pkgdir}/usr/${_arch}/bin/*.dll
${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
done
diff --git a/configure.patch b/configure.patch
index cc3ed17acc82..560ad66a1591 100644
--- a/configure.patch
+++ b/configure.patch
@@ -1,7 +1,7 @@
-diff -ru libvpx-1.6.0/build/make/configure.sh patched/build/make/configure.sh
---- libvpx-1.6.0/build/make/configure.sh 2016-07-21 03:15:41.000000000 +0200
-+++ patched/build/make/configure.sh 2016-08-09 19:20:40.093060169 +0200
-@@ -1308,11 +1308,13 @@
+diff -ru libvpx-1.6.1/build/make/configure.sh patched/build/make/configure.sh
+--- libvpx-1.6.1/build/make/configure.sh 2017-01-12 21:27:27.000000000 +0100
++++ patched/build/make/configure.sh 2017-04-14 12:02:03.691725079 +0200
+@@ -1279,11 +1279,13 @@
win32)
add_asflags -f win32
enabled debug && add_asflags -g cv8
@@ -15,9 +15,9 @@ diff -ru libvpx-1.6.0/build/make/configure.sh patched/build/make/configure.sh
EXE_SFX=.exe
;;
linux*|solaris*|android*)
-diff -ru libvpx-1.6.0/build/make/Makefile patched/build/make/Makefile
---- libvpx-1.6.0/build/make/Makefile 2016-07-21 03:15:41.000000000 +0200
-+++ patched/build/make/Makefile 2016-08-09 19:20:40.093060169 +0200
+diff -ru libvpx-1.6.1/build/make/Makefile patched/build/make/Makefile
+--- libvpx-1.6.1/build/make/Makefile 2017-01-12 21:27:27.000000000 +0100
++++ patched/build/make/Makefile 2017-04-14 12:02:03.691725079 +0200
@@ -296,6 +296,7 @@
$(if $(quiet),@echo " [LD] $$@")
$(qexec)$$(LD) -shared $$(LDFLAGS) \
@@ -35,10 +35,10 @@ diff -ru libvpx-1.6.0/build/make/Makefile patched/build/make/Makefile
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dylib,$(LIBS)),$(eval $(call dl_template,$(lib))))
$(foreach lib,$(filter %$(SO_VERSION_MAJOR).dll,$(LIBS)),$(eval $(call dll_template,$(lib))))
-diff -ru libvpx-1.6.0/configure patched/configure
---- libvpx-1.6.0/configure 2016-07-21 03:15:41.000000000 +0200
-+++ patched/configure 2016-08-09 19:22:26.015003259 +0200
-@@ -500,23 +500,23 @@
+diff -ru libvpx-1.6.1/configure patched/configure
+--- libvpx-1.6.1/configure 2017-01-12 21:27:27.000000000 +0100
++++ patched/configure 2017-04-14 12:02:03.691725079 +0200
+@@ -491,23 +491,23 @@
}
process_detect() {
@@ -75,10 +75,22 @@ diff -ru libvpx-1.6.0/configure patched/configure
if [ -z "$CC" ] || enabled external_build; then
echo "Bypassing toolchain for environment detection."
enable_feature external_build
-diff -ru libvpx-1.6.0/libs.mk patched/libs.mk
---- libvpx-1.6.0/libs.mk 2016-07-21 03:15:41.000000000 +0200
-+++ patched/libs.mk 2016-08-09 19:20:40.093060169 +0200
-@@ -252,12 +252,12 @@
+diff -ru libvpx-1.6.1/examples.mk patched/examples.mk
+--- libvpx-1.6.1/examples.mk 2017-01-12 21:27:27.000000000 +0100
++++ patched/examples.mk 2017-04-14 12:07:14.397325649 +0200
+@@ -314,7 +314,7 @@
+ ifneq ($(filter os2%,$(TGT_OS)),)
+ SHARED_LIB_SUF=_dll.a
+ else
+-SHARED_LIB_SUF=.so
++SHARED_LIB_SUF=.dll.a
+ endif
+ endif
+ CODEC_LIB_SUF=$(if $(CONFIG_SHARED),$(SHARED_LIB_SUF),.a)
+diff -ru libvpx-1.6.1/libs.mk patched/libs.mk
+--- libvpx-1.6.1/libs.mk 2017-01-12 21:27:27.000000000 +0100
++++ patched/libs.mk 2017-04-14 12:02:03.701725259 +0200
+@@ -255,12 +255,12 @@
LIBVPX_SO_SYMLINKS :=
LIBVPX_SO_IMPLIB := libvpx_dll.a
else
@@ -95,7 +107,7 @@ diff -ru libvpx-1.6.0/libs.mk patched/libs.mk
endif
endif
endif
-@@ -267,7 +267,7 @@
+@@ -270,7 +270,7 @@
$(if $(LIBVPX_SO_IMPLIB), $(BUILD_PFX)$(LIBVPX_SO_IMPLIB))
$(BUILD_PFX)$(LIBVPX_SO): $(LIBVPX_OBJS) $(EXPORT_FILE)
$(BUILD_PFX)$(LIBVPX_SO): extralibs += -lm