summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2015-11-03 16:04:24 -0800
committerBuildTools2015-11-03 16:04:24 -0800
commit4096123c4ca3d6b4c9d8f36d7cd1e03e3263e333 (patch)
treed7fcb43d8b7afbccd439e56e6155b0fc2bc4c3fb
parent6bec8b7d4cb41e87b2345763a03a60e1006470bb (diff)
downloadaur-4096123c4ca3d6b4c9d8f36d7cd1e03e3263e333.tar.gz
0.4.4
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
3 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 606c4ce5bc49..5614700fd72a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mingw-w64-libwebp
pkgdesc = WebP library (mingw-w64)
- pkgver = 0.4.3
+ pkgver = 0.4.4
pkgrel = 1
- url = https://developers.google.com/speed/webp
+ url = https://developers.google.com/speed/webp/
arch = any
license = BSD
makedepends = mingw-w64-configure
@@ -14,8 +14,8 @@ pkgbase = mingw-w64-libwebp
options = staticlibs
options = !strip
options = !buildflags
- source = http://downloads.webmproject.org/releases/webp/libwebp-0.4.3.tar.gz
- sha256sums = efbe0d58fda936f2ed99d0b837ed7087d064d6838931f282c4618d2a3f7390c4
+ source = http://downloads.webmproject.org/releases/webp/libwebp-0.4.4.tar.gz
+ sha256sums = c65d34edb57338e331ba4d622227a2b3179444cfca17d02c34f1ead63f603e86
pkgname = mingw-w64-libwebp
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25cca9a92b37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
index fd58936728ca..946efd0dc16f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
pkgname=mingw-w64-libwebp
-pkgver=0.4.3
+pkgver=0.4.4
pkgrel=1
pkgdesc="WebP library (mingw-w64)"
arch=(any)
-url="https://developers.google.com/speed/webp"
+url="https://developers.google.com/speed/webp/"
license=("BSD")
makedepends=(mingw-w64-configure)
depends=(mingw-w64-libjpeg-turbo mingw-w64-libpng mingw-w64-libtiff mingw-w64-freeglut mingw-w64-giflib)
options=(staticlibs !strip !buildflags)
source=("http://downloads.webmproject.org/releases/webp/libwebp-$pkgver.tar.gz")
-sha256sums=('efbe0d58fda936f2ed99d0b837ed7087d064d6838931f282c4618d2a3f7390c4')
+sha256sums=('c65d34edb57338e331ba4d622227a2b3179444cfca17d02c34f1ead63f603e86')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -33,9 +33,9 @@ package() {
for _arch in ${_architectures}; do
cd "$srcdir/libwebp-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
- find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
rm -r "$pkgdir/usr/${_arch}/share"
done
}