summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-08-19 00:09:06 -0700
committerSchala2016-08-19 00:09:06 -0700
commitc07da755f21b840474fe89e7dae9e47ab66bb4c7 (patch)
tree0e6636089399e565e0a27e31518065b68570471f
parent1f00ff66f5d85307873fd13a168ca88f722686e7 (diff)
downloadaur-c07da755f21b840474fe89e7dae9e47ab66bb4c7.tar.gz
keep EXEs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abd61f02bb86..5f86ceef5ff7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 25 18:18:33 UTC 2016
+# Fri Aug 19 07:07:57 UTC 2016
pkgbase = mingw-w64-libwebp
- pkgdesc = WebP library (mingw-w64)
+ pkgdesc = WebP library and conversion tools (mingw-w64)
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://developers.google.com/speed/webp/
arch = any
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 3cc85c7e07fe..df00196ceca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-libwebp
pkgver=0.5.1
-pkgrel=1
-pkgdesc="WebP library (mingw-w64)"
+pkgrel=2
+pkgdesc="WebP library and conversion tools (mingw-w64)"
arch=(any)
url="https://developers.google.com/speed/webp/"
license=("BSD")
@@ -31,9 +31,9 @@ package() {
for _arch in ${_architectures}; do
cd "$srcdir/libwebp-$pkgver/build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec rm {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- rm -r "$pkgdir/usr/${_arch}/share"
+ #rm -r "$pkgdir/usr/${_arch}/share"
done
}