summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2017-04-29 22:09:17 -0700
committerSchala2017-04-29 22:09:17 -0700
commitd01fbdbfe0dd1c3c0b5e62e2bf05281c3d310139 (patch)
treea1adba591ce193eded2dbef0836777dd747a405f
parent7c41bc7430bfb38ce881f6bf20bd916deca3f112 (diff)
downloadaur-d01fbdbfe0dd1c3c0b5e62e2bf05281c3d310139.tar.gz
0.6
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
3 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e7183061d24..1fde4f6ac03d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Jan 13 10:19:30 UTC 2017
+# Sun Apr 30 05:08:47 UTC 2017
pkgbase = mingw-w64-libwebp
pkgdesc = WebP library and conversion tools (mingw-w64)
- pkgver = 0.5.2
+ pkgver = 0.6.0
pkgrel = 1
url = https://developers.google.com/speed/webp/
arch = any
license = BSD
makedepends = mingw-w64-configure
+ makedepends = git
depends = mingw-w64-libjpeg-turbo
depends = mingw-w64-libpng
depends = mingw-w64-libtiff
@@ -15,8 +16,8 @@ pkgbase = mingw-w64-libwebp
options = staticlibs
options = !strip
options = !buildflags
- source = http://downloads.webmproject.org/releases/webp/libwebp-0.5.2.tar.gz
- sha256sums = b75310c810b3eda222c77f6d6c26b061240e3d9060095de44b2c1bae291ecdef
+ source = git+https://chromium.googlesource.com/webm/libwebp#commit=50d1a848bc56554af8413cfe681f94286a6371b3
+ sha256sums = SKIP
pkgname = mingw-w64-libwebp
diff --git a/.gitignore b/.gitignore
index 49c4674d6625..78bc652a67b0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+libwebp/
pkg/
src/
*.gz
diff --git a/PKGBUILD b/PKGBUILD
index bdd19d0a500f..8d13c622be9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,32 @@
pkgname=mingw-w64-libwebp
-pkgver=0.5.2
+pkgver=0.6.0
pkgrel=1
+_commit=50d1a848bc56554af8413cfe681f94286a6371b3 # tags/v0.6.0^0
pkgdesc="WebP library and conversion tools (mingw-w64)"
arch=(any)
url="https://developers.google.com/speed/webp/"
license=("BSD")
-makedepends=(mingw-w64-configure)
+makedepends=(mingw-w64-configure git)
depends=(mingw-w64-libjpeg-turbo mingw-w64-libpng mingw-w64-libtiff mingw-w64-giflib)
options=(staticlibs !strip !buildflags)
-source=("http://downloads.webmproject.org/releases/webp/libwebp-$pkgver.tar.gz")
-sha256sums=('b75310c810b3eda222c77f6d6c26b061240e3d9060095de44b2c1bae291ecdef')
+source=("git+https://chromium.googlesource.com/webm/libwebp#commit=$_commit")
+sha256sums=('SKIP')
+validpgpkeys=('6B0E6B70976DE303EDF2F601F9C3D6BDB8232B5D')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd "$srcdir/libwebp"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd "$srcdir/libwebp"
+ NOCONFIGURE=1 ./autogen.sh
+}
+
build() {
- cd "$srcdir/libwebp-$pkgver"
+ cd "$srcdir/libwebp"
for _arch in ${_architectures}; do
unset LDFLAGS
mkdir -p build-${_arch} && pushd build-${_arch}
@@ -29,11 +41,10 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/libwebp-$pkgver/build-${_arch}"
+ cd "$srcdir/libwebp/build-${_arch}"
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
- #rm -r "$pkgdir/usr/${_arch}/share"
done
}