summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2015-08-24 09:23:13 +0200
committerJens Staal2015-08-24 09:23:13 +0200
commit99657a5e3b6448670ae274be8731a4b8d16dd4f5 (patch)
treec2f2c1662c77ae402480bb96d90bc85ca93a194d
downloadaur-99657a5e3b6448670ae274be8731a4b8d16dd4f5.tar.gz
temporary commit :xcb work-in-progress
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD73
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afb2a53573a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-libxcb-win32-git
+ pkgdesc = X11 client-side library on top of Win32 - git version (mingw-w64)
+ pkgver = 1.11.r59.g4033d39
+ pkgrel = 1
+ url = http://xcb.freedesktop.org/win32port/
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = libxslt
+ makedepends = python
+ depends = mingw-w64-crt
+ depends = mingw-w64-libxau
+ depends = mingw-w64-winpthreads
+ depends = mingw-w64-libxdmcp
+ depends = mingw-w64-xcb-proto
+ provides = mingw-w64-libxcb=1.11.r59.g4033d39
+ options = !strip
+ options = staticlibs
+ options = !buildflags
+ source = xcb-win32::git+http://anongit.freedesktop.org/git/xcb/libxcb.git
+ sha256sums = SKIP
+
+pkgname = mingw-w64-libxcb-win32-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7dcbe2dd34c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Jens Staal <staal1978@gmail.com>
+# adopted from libxcb-git package:
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: NeoRaider <neoraider@universe-factory.net>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=mingw-w64-libxcb-win32-git
+pkgver=1.11.r59.g4033d39
+pkgrel=1
+pkgdesc="X11 client-side library on top of Win32 - git version (mingw-w64)"
+arch=('any')
+url="http://xcb.freedesktop.org/win32port/"
+depends=('mingw-w64-crt' 'mingw-w64-libxau' 'mingw-w64-winpthreads' \
+'mingw-w64-libxdmcp' 'mingw-w64-xcb-proto')
+makedepends=('git' 'libxslt' 'python')
+provides=("mingw-w64-libxcb=$pkgver")
+license=('custom')
+source=('xcb-win32'::'git+http://anongit.freedesktop.org/git/xcb/libxcb.git')
+sha256sums=('SKIP')
+options=('!strip' 'staticlibs' '!buildflags')
+
+_architectures="i686-w64-mingw32"
+# x86_64-w64-mingw32 build errors in libxdmcp dependency - conflicting types
+
+pkgver() {
+ cd "${srcdir}"/xcb-win32
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+prepare() {
+ cd "${srcdir}"/xcb-win32
+ sed 's|pthread-stubs xau >=|xau >=|g' -i configure.ac
+}
+
+build() {
+ cd "${srcdir}"/xcb-win32
+
+ #generic, to make configure
+ ./autogen.sh \
+ --host=i686-w64-mingw32 \
+ --prefix=/usr/i686-w64-mingw32 \
+ --enable-xinput \
+ --enable-xkb
+
+ make distclean
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
+ export CXXFLAGS=$CFLAGS
+ export LDFLAGS="$LDFLAGS -lssp -lws2_32 -lwinpthread"
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}"/xcb-win32
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/xcb-win32/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm -r "${pkgdir}/usr/${_arch}/share"
+ rm -f "${pkgdir}"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
+}
+# vim:set ts=2 sw=2 bs=2: