summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-05-25 20:46:37 +0200
committerMichel Zou2016-05-25 20:46:37 +0200
commitad81574b2a9be51b197c1c6d617ce982e0314113 (patch)
tree86328bc18b4d9f8df7f4dd6bf9c11fa0dfbde757
parent4132370e7c1c3ba3818e3ca77770914335d793c0 (diff)
downloadaur-ad81574b2a9be51b197c1c6d617ce982e0314113.tar.gz
2.9.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--libxml2-no-test.patch15
3 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a4246775f20..bc9aa71a4183 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 6 17:05:01 UTC 2016
+# Wed May 25 18:46:37 UTC 2016
pkgbase = mingw-w64-libxml2
pkgdesc = XML parsing library, version 2 (mingw-w64)
- pkgver = 2.9.3
+ pkgver = 2.9.4
pkgrel = 1
url = http://www.xmlsoft.org/
arch = any
@@ -15,12 +15,12 @@ pkgbase = mingw-w64-libxml2
options = !buildflags
options = !strip
options = staticlibs
- source = http://xmlsoft.org/sources/libxml2-2.9.3.tar.gz
+ source = http://xmlsoft.org/sources/libxml2-2.9.4.tar.gz
source = mingw32-libxml2-static-build-compile-fix.patch
source = libxml2-no-test.patch
- md5sums = daece17e045f1c107610e137ab50c179
+ md5sums = ae249165c173b1ff386ee8ad676815f5
md5sums = 0df377025082cd93cccbca547f048011
- md5sums = ddd73e88dda6ae318267507409445b7d
+ md5sums = db4d3c38434b1a1b5d2a29cd30e7228e
pkgname = mingw-w64-libxml2
diff --git a/PKGBUILD b/PKGBUILD
index b42e71d38589..e55057625d9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
pkgname=mingw-w64-libxml2
-pkgver=2.9.3
+pkgver=2.9.4
pkgrel=1
arch=('any')
pkgdesc="XML parsing library, version 2 (mingw-w64)"
@@ -13,36 +13,38 @@ url="http://www.xmlsoft.org/"
source=("http://xmlsoft.org/sources/libxml2-${pkgver}.tar.gz"
"mingw32-libxml2-static-build-compile-fix.patch"
"libxml2-no-test.patch")
-md5sums=('daece17e045f1c107610e137ab50c179'
+md5sums=('ae249165c173b1ff386ee8ad676815f5'
'0df377025082cd93cccbca547f048011'
- 'ddd73e88dda6ae318267507409445b7d')
+ 'db4d3c38434b1a1b5d2a29cd30e7228e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "${srcdir}/libxml2-${pkgver}"
+
+ # fedora patch, purpose ?
patch -Np0 -i "${srcdir}"/mingw32-libxml2-static-build-compile-fix.patch
+
+ # disable tests
patch -Np1 -i "${srcdir}"/libxml2-no-test.patch
+
+ # disable doc & examples
sed -i "s| doc example | |g" Makefile.am
- sed -i "s|LIBXML_STATIC|_WIN32|g" include/libxml/xmlexports.h
autoreconf -vfi
}
build()
{
cd "${srcdir}/libxml2-${pkgver}"
-
- # Static build
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
- --without-python \
- --enable-ipv6 \
- --with-modules LIBS="-lz"
+ --without-python
make
- # deps symbols are not included:
+ # deps symbols are not included in static lib:
${_arch}-ar x /usr/${_arch}/lib/libiconv.a
+ ${_arch}-ar x /usr/${_arch}/lib/liblzma.a
${_arch}-ar x /usr/${_arch}/lib/libz.a
${_arch}-ar x /usr/${_arch}/lib/libws2_32.a
${_arch}-ar cru .libs/libxml2.a *.o
diff --git a/libxml2-no-test.patch b/libxml2-no-test.patch
index 386ae4d78698..753ecdd8f139 100644
--- a/libxml2-no-test.patch
+++ b/libxml2-no-test.patch
@@ -1,7 +1,8 @@
-diff -ur libxml2-2.9.1.orig/Makefile.am libxml2-2.9.1/Makefile.am
---- libxml2-2.9.1.orig/Makefile.am 2013-11-30 16:46:20.273724298 +0100
-+++ libxml2-2.9.1/Makefile.am 2013-11-30 16:49:40.131795741 +0100
-@@ -10,11 +10,6 @@
+diff --git a/Makefile.am b/Makefile.am
+index 9f988b0..5bbdf08 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,11 +10,6 @@ AM_CPPFLAGS = -I$(top_builddir)/include -I$(srcdir)/include
AM_CFLAGS = $(THREAD_CFLAGS) $(Z_CFLAGS) $(LZMA_CFLAGS)
@@ -13,7 +14,7 @@ diff -ur libxml2-2.9.1.orig/Makefile.am libxml2-2.9.1/Makefile.am
bin_PROGRAMS = xmllint xmlcatalog
bin_SCRIPTS=xml2-config
-@@ -66,1097 +61,16 @@
+@@ -66,1101 +61,16 @@ man_MANS = xml2-config.1 libxml.3
m4datadir = $(datadir)/aclocal
m4data_DATA = libxml.m4
@@ -167,6 +168,10 @@ diff -ur libxml2-2.9.1.orig/Makefile.am libxml2-2.9.1/Makefile.am
- @echo '## Go get a cup of coffee it is gonna take a while ...'
- $(MAKE) CHECKER='valgrind -q' runtests
-
+-asan:
+- @echo '## rebuilding for ASAN'
+- ./configure CFLAGS="-fsanitize=address,undefined -Wformat -Werror=format-security -Werror=array-bounds -g" CXXFLAGS="-fsanitize=address,undefined -Wformat -Werror=format-security -Werror=array-bounds -g" LDFLAGS="-fsanitize=address,undefined" CC="clang" CXX="clang++" --disable-shared ; OptimOff ; $(MAKE) clean ; $(MAKE)
+-
-testall : tests SVGtests SAXtests
-
-tests: XMLtests XMLenttests NStests IDtests Errtests APItests $(READER_TEST) $(TEST_SAX) $(TEST_PUSH) $(TEST_HTML) $(TEST_PHTML) $(TEST_VALID) URItests $(TEST_PATTERN) $(TEST_XPATH) $(TEST_XPTR) $(TEST_XINCLUDE) $(TEST_C14N) $(TEST_DEBUG) $(TEST_CATALOG) $(TEST_REGEXPS) $(TEST_SCHEMAS) $(TEST_SCHEMATRON) $(TEST_THREADS) Timingtests $(TEST_VTIME) $(PYTHON_TESTS) $(TEST_MODULES)