summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2015-06-08 19:26:47 -0700
committerSchala2015-06-08 19:26:47 -0700
commit35b257594306a2da229b17e829bb113635a18fda (patch)
tree9279f50ab01f27e9b3e9900f6a64cd92c72cb97e
downloadaur-35b257594306a2da229b17e829bb113635a18fda.tar.gz
added patches from https://github.com/Alexpux/MINGW-packages/blob/master/mingw-w64-libxslt
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--0005-fix-freelocales-export.all.patch18
-rw-r--r--PKGBUILD55
-rw-r--r--libxslt-1.1.26-w64.patch13
-rw-r--r--libxslt-1.1.28-win32-shared.patch33
-rw-r--r--mingw32-libxslt-use-correct-mkdir.patch14
7 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f0807b2b63e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mingw-w64-libxslt
+ pkgdesc = XML stylesheet transformation library (mingw-w64)
+ pkgver = 1.1.28
+ pkgrel = 6
+ url = http://xmlsoft.org/XSLT
+ arch = any
+ license = custom
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ depends = mingw-w64-libxml2
+ depends = mingw-w64-libgcrypt
+ options = !strip
+ options = staticlibs
+ options = !buildflags
+ source = http://xmlsoft.org/sources/libxslt-1.1.28.tar.gz
+ source = mingw32-libxslt-use-correct-mkdir.patch
+ source = 0005-fix-freelocales-export.all.patch
+ source = libxslt-1.1.26-w64.patch
+ source = libxslt-1.1.28-win32-shared.patch
+ md5sums = 9667bf6f9310b957254fdcf6596600b7
+ md5sums = d9a2f525f8f703d8e2000000dcaa943e
+ md5sums = ee6e3e375b8ea2f42c7039e13f14f0c8
+ md5sums = b994c0d9df0f644e219cf63561ee0d4e
+ md5sums = 19646f155b518b40cb63e41270215964
+
+pkgname = mingw-w64-libxslt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..25cca9a92b37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.gz
+*.xz
diff --git a/0005-fix-freelocales-export.all.patch b/0005-fix-freelocales-export.all.patch
new file mode 100644
index 000000000000..bea1d4d3691c
--- /dev/null
+++ b/0005-fix-freelocales-export.all.patch
@@ -0,0 +1,18 @@
+--- libxslt-1.1.27/libxslt/xsltlocale.h.orig 2012-09-26 17:54:17 +0400
++++ libxslt-1.1.27/libxslt/xsltlocale.h 2012-09-26 18:08:49 +0400
+@@ -12,6 +12,7 @@
+ #define __XML_XSLTLOCALE_H__
+
+ #include <libxml/xmlstring.h>
++#include "xsltexports.h"
+
+ #ifdef XSLT_LOCALE_XLOCALE
+
+@@ -53,6 +53,6 @@
+ void xsltFreeLocale(xsltLocale locale);
+ xsltLocaleChar *xsltStrxfrm(xsltLocale locale, const xmlChar *string);
+ int xsltLocaleStrcmp(xsltLocale locale, const xsltLocaleChar *str1, const xsltLocaleChar *str2);
+-void xsltFreeLocales(void);
++XSLTPUBFUN void XSLTCALL xsltFreeLocales (void);
+
+ #endif /* __XML_XSLTLOCALE_H__ */
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9c8866ac9f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+pkgname=mingw-w64-libxslt
+pkgver=1.1.28
+pkgrel=6
+pkgdesc="XML stylesheet transformation library (mingw-w64)"
+arch=(any)
+url="http://xmlsoft.org/XSLT"
+license=(custom)
+depends=(mingw-w64-crt mingw-w64-libxml2 mingw-w64-libgcrypt)
+makedepends=(mingw-w64-configure)
+options=(!strip staticlibs !buildflags)
+source=("http://xmlsoft.org/sources/libxslt-${pkgver}.tar.gz"
+"mingw32-libxslt-use-correct-mkdir.patch"
+"0005-fix-freelocales-export.all.patch"
+"libxslt-1.1.26-w64.patch"
+"libxslt-1.1.28-win32-shared.patch")
+md5sums=('9667bf6f9310b957254fdcf6596600b7'
+ 'd9a2f525f8f703d8e2000000dcaa943e'
+ 'ee6e3e375b8ea2f42c7039e13f14f0c8'
+ 'b994c0d9df0f644e219cf63561ee0d4e'
+ '19646f155b518b40cb63e41270215964')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd libxslt-${pkgver}
+ patch -p1 -i "${srcdir}/libxslt-1.1.26-w64.patch"
+ patch -p1 -i "${srcdir}/libxslt-1.1.28-win32-shared.patch"
+ patch -p0 -i "${srcdir}/mingw32-libxslt-use-correct-mkdir.patch"
+ patch -p1 -i "${srcdir}/0005-fix-freelocales-export.all.patch"
+ autoreconf -fi
+}
+
+build() {
+ cd "$srcdir/libxslt-${pkgver}"
+ unset LDFLAGS
+ for _arch in ${_architectures}; do
+ mkdir -p "build-${_arch}" && pushd "build-${_arch}"
+ ${_arch}-configure \
+ --with-libxml-prefix=/usr/${_arch} \
+ --without-python
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/libxslt-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/${_arch}/share
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ done
+}
+
diff --git a/libxslt-1.1.26-w64.patch b/libxslt-1.1.26-w64.patch
new file mode 100644
index 000000000000..ea63954a5f5d
--- /dev/null
+++ b/libxslt-1.1.26-w64.patch
@@ -0,0 +1,13 @@
+diff -ur libxslt-1.1.26/configure.in libxslt-1.1.26/configure.in
+--- libxslt-1.1.26/configure.in 2009-09-24 16:27:30.000000000 +0200
++++ libxslt-1.1.26/configure.in 2009-11-11 17:51:06.000000000 +0100
+@@ -627,7 +627,7 @@
+ WIN32_EXTRA_LDFLAGS="-no-undefined"
+ ;;
+ *-*-mingw*)
+- WIN32_EXTRA_LIBADD="-lwsock32"
++ WIN32_EXTRA_LIBADD="-lws2_32 -lmswsock"
+ WIN32_EXTRA_LDFLAGS="-no-undefined"
+ AC_DEFINE([_WINSOCKAPI_],1,[Using the Win32 Socket implementation])
+ AC_DEFINE([snprintf],[_snprintf],[Win32 Std C name mangling work-around])
+Only in libxslt-1.1.26: configure.in.orig
diff --git a/libxslt-1.1.28-win32-shared.patch b/libxslt-1.1.28-win32-shared.patch
new file mode 100644
index 000000000000..6534de3c9d60
--- /dev/null
+++ b/libxslt-1.1.28-win32-shared.patch
@@ -0,0 +1,33 @@
+--- libxslt-1.1.27/configure.in.orig 2012-09-17 13:01:19 +0400
++++ libxslt-1.1.27/configure.in 2012-09-17 13:01:57 +0400
+@@ -3,6 +3,7 @@
+ AC_INIT(libxslt/xslt.c)
+ AC_CONFIG_HEADERS(config.h)
+ AC_CANONICAL_HOST
++AC_LIBTOOL_WIN32_DLL
+ AC_USE_SYSTEM_EXTENSIONS
+
+ dnl
+--- libxslt-1.1.27/libexslt/Makefile.am.orig 2012-09-17 13:00:51 +0400
++++ libxslt-1.1.27/libexslt/Makefile.am 2012-09-17 13:01:45 +0400
+@@ -27,7 +27,7 @@
+ dynamic.c
+
+ libexslt_la_LIBADD = $(top_builddir)/libxslt/libxslt.la $(EXTRA_LIBS) $(LIBGCRYPT_LIBS)
+-libexslt_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -version-info $(LIBEXSLT_VERSION_INFO)
++libexslt_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -version-info $(LIBEXSLT_VERSION_INFO) -no-undefined
+
+ man_MANS = libexslt.3
+
+--- libxslt-1.1.27/libxslt/Makefile.am.orig 2012-09-17 13:01:08 +0400
++++ libxslt-1.1.27/libxslt/Makefile.am 2012-09-17 13:01:37 +0400
+@@ -64,7 +64,8 @@
+ libxslt_la_LDFLAGS = \
+ $(WIN32_EXTRA_LDFLAGS) \
+ $(LIBXSLT_VERSION_SCRIPT) \
+- -version-info $(LIBXSLT_VERSION_INFO)
++ -version-info $(LIBXSLT_VERSION_INFO) \
++ -no-undefined
+
+ man_MANS = libxslt.3
+
diff --git a/mingw32-libxslt-use-correct-mkdir.patch b/mingw32-libxslt-use-correct-mkdir.patch
new file mode 100644
index 000000000000..6f58d374671c
--- /dev/null
+++ b/mingw32-libxslt-use-correct-mkdir.patch
@@ -0,0 +1,14 @@
+--- libxslt/security.c.orig 2010-10-13 15:42:00.790273503 +0200
++++ libxslt/security.c 2010-10-13 15:42:34.425556664 +0200
+@@ -343,7 +343,11 @@
+ }
+ ret = xsltCheckWritePath(sec, ctxt, directory);
+ if (ret == 1)
++#ifdef WIN32
++ ret = mkdir(directory);
++#else
+ ret = mkdir(directory, 0755);
++#endif
+ }
+ xmlFree(directory);
+ if (ret < 0)