summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2016-01-13 15:33:36 -0800
committerBuildTools2016-01-13 15:33:36 -0800
commitaf88beca174be3c33b527ff3628ec103476e2856 (patch)
treec312ca3b2c0435064f6af3c60d084ee5d84e2239
parent35b257594306a2da229b17e829bb113635a18fda (diff)
downloadaur-af88beca174be3c33b527ff3628ec103476e2856.tar.gz
CVE-2015-7995
-rw-r--r--.SRCINFO6
-rw-r--r--CVE-2015-7995.patch29
-rw-r--r--PKGBUILD9
3 files changed, 40 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f0807b2b63e..db261d15a8c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 23:33:13 UTC 2016
pkgbase = mingw-w64-libxslt
pkgdesc = XML stylesheet transformation library (mingw-w64)
pkgver = 1.1.28
- pkgrel = 6
+ pkgrel = 7
url = http://xmlsoft.org/XSLT
arch = any
license = custom
@@ -17,11 +19,13 @@ pkgbase = mingw-w64-libxslt
source = 0005-fix-freelocales-export.all.patch
source = libxslt-1.1.26-w64.patch
source = libxslt-1.1.28-win32-shared.patch
+ source = CVE-2015-7995.patch
md5sums = 9667bf6f9310b957254fdcf6596600b7
md5sums = d9a2f525f8f703d8e2000000dcaa943e
md5sums = ee6e3e375b8ea2f42c7039e13f14f0c8
md5sums = b994c0d9df0f644e219cf63561ee0d4e
md5sums = 19646f155b518b40cb63e41270215964
+ md5sums = b97b695cbe4171f8cb10df41f652aba5
pkgname = mingw-w64-libxslt
diff --git a/CVE-2015-7995.patch b/CVE-2015-7995.patch
new file mode 100644
index 000000000000..fbcd7ea9055c
--- /dev/null
+++ b/CVE-2015-7995.patch
@@ -0,0 +1,29 @@
+From 7ca19df892ca22d9314e95d59ce2abdeff46b617 Mon Sep 17 00:00:00 2001
+From: Daniel Veillard <veillard@redhat.com>
+Date: Thu, 29 Oct 2015 19:33:23 +0800
+Subject: Fix for type confusion in preprocessing attributes
+
+CVE-2015-7995 http://www.openwall.com/lists/oss-security/2015/10/27/10
+We need to check that the parent node is an element before dereferencing
+its namespace
+---
+ libxslt/preproc.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libxslt/preproc.c b/libxslt/preproc.c
+index 0eb80a0..7f69325 100644
+--- a/libxslt/preproc.c
++++ b/libxslt/preproc.c
+@@ -2249,7 +2249,8 @@ xsltStylePreCompute(xsltStylesheetPtr style, xmlNodePtr inst) {
+ } else if (IS_XSLT_NAME(inst, "attribute")) {
+ xmlNodePtr parent = inst->parent;
+
+- if ((parent == NULL) || (parent->ns == NULL) ||
++ if ((parent == NULL) ||
++ (parent->type != XML_ELEMENT_NODE) || (parent->ns == NULL) ||
+ ((parent->ns != inst->ns) &&
+ (!xmlStrEqual(parent->ns->href, inst->ns->href))) ||
+ (!xmlStrEqual(parent->name, BAD_CAST "attribute-set"))) {
+--
+cgit v0.11.2
+
diff --git a/PKGBUILD b/PKGBUILD
index c9c8866ac9f3..0b67fa5b8f47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-libxslt
pkgver=1.1.28
-pkgrel=6
+pkgrel=7
pkgdesc="XML stylesheet transformation library (mingw-w64)"
arch=(any)
url="http://xmlsoft.org/XSLT"
@@ -12,12 +12,14 @@ source=("http://xmlsoft.org/sources/libxslt-${pkgver}.tar.gz"
"mingw32-libxslt-use-correct-mkdir.patch"
"0005-fix-freelocales-export.all.patch"
"libxslt-1.1.26-w64.patch"
-"libxslt-1.1.28-win32-shared.patch")
+"libxslt-1.1.28-win32-shared.patch"
+"CVE-2015-7995.patch")
md5sums=('9667bf6f9310b957254fdcf6596600b7'
'd9a2f525f8f703d8e2000000dcaa943e'
'ee6e3e375b8ea2f42c7039e13f14f0c8'
'b994c0d9df0f644e219cf63561ee0d4e'
- '19646f155b518b40cb63e41270215964')
+ '19646f155b518b40cb63e41270215964'
+ 'b97b695cbe4171f8cb10df41f652aba5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
@@ -26,6 +28,7 @@ prepare() {
patch -p1 -i "${srcdir}/libxslt-1.1.28-win32-shared.patch"
patch -p0 -i "${srcdir}/mingw32-libxslt-use-correct-mkdir.patch"
patch -p1 -i "${srcdir}/0005-fix-freelocales-export.all.patch"
+ patch -Np1 -i ../CVE-2015-7995.patch
autoreconf -fi
}