summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-11-12 23:05:22 -0500
committerPatrick Northon2021-11-12 23:05:22 -0500
commitc8ad7920212715cc93fc3c14efeee51e7548a3f8 (patch)
tree7b7816776e21a9df22cde75c49fe85c4a493dc87
parentd2799efa29ed6266aeb9b63639ae79d1ec9ee720 (diff)
downloadaur-c8ad7920212715cc93fc3c14efeee51e7548a3f8.tar.gz
Update version.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
-rw-r--r--libxslt-1.1.26-w64.patch13
-rw-r--r--libxslt.m4-libxslt-1.1.26.patch38
4 files changed, 24 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34a76477c1c4..8a5f808b3fa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,20 @@
-# Generated by mksrcinfo v8
-# Thu Mar 23 03:00:29 UTC 2017
pkgbase = mingw-w64-libxslt
pkgdesc = XML stylesheet transformation library (mingw-w64)
- pkgver = 1.1.29+42+gac341cbd
+ pkgver = 1.1.34
pkgrel = 1
url = http://xmlsoft.org/XSLT/
arch = any
license = custom
makedepends = mingw-w64-configure
- makedepends = git
depends = mingw-w64-libxml2
depends = mingw-w64-libgcrypt
options = !strip
options = staticlibs
options = !buildflags
options = !emptydirs
- source = git://git.gnome.org/libxslt#commit=ac341cbd792ee572941cc9a66e73800219a1a386
- source = libxslt-1.1.26-w64.patch
- source = libxslt.m4-libxslt-1.1.26.patch
+ source = https://gitlab.gnome.org/GNOME/libxslt/-/archive/v1.1.34/libxslt-v1.1.34.tar.bz2
source = 0003-fix-concurrent-directory-creation.all.patch
- md5sums = SKIP
- md5sums = b994c0d9df0f644e219cf63561ee0d4e
- md5sums = 61b520bbd42006c16bbfc85bc5342b96
- md5sums = 6da8eb266e6be4f843cf63bd74c6388b
+ sha256sums = 34c44ba31397b471e7c36a0b07ff2e56c30a20a0a280caba0ad13fb0adbbc8e5
+ sha256sums = fc23bd3c9e62a28cb1c020cebc83ca7532a5a7a21c2e4748b72d13ac7716a851
pkgname = mingw-w64-libxslt
-
diff --git a/PKGBUILD b/PKGBUILD
index edc17a56ad03..b2341f8b6040 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,33 @@
-pkgname=mingw-w64-libxslt
-pkgver=1.1.29+42+gac341cbd
-_commit=ac341cbd792ee572941cc9a66e73800219a1a386
+_pkgname=libxslt
+pkgname=mingw-w64-${_pkgname}
+pkgver=1.1.34
pkgrel=1
pkgdesc="XML stylesheet transformation library (mingw-w64)"
arch=(any)
url="http://xmlsoft.org/XSLT/"
license=("custom")
depends=(mingw-w64-libxml2 mingw-w64-libgcrypt)
-makedepends=(mingw-w64-configure git)
+makedepends=(mingw-w64-configure)
options=(!strip staticlibs !buildflags !emptydirs)
-source=("git://git.gnome.org/libxslt#commit=$_commit"
-"libxslt-1.1.26-w64.patch"
-"libxslt.m4-libxslt-1.1.26.patch"
-"0003-fix-concurrent-directory-creation.all.patch")
-md5sums=('SKIP'
- 'b994c0d9df0f644e219cf63561ee0d4e'
- '61b520bbd42006c16bbfc85bc5342b96'
- '6da8eb266e6be4f843cf63bd74c6388b')
+source=("https://gitlab.gnome.org/GNOME/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.bz2"
+ "0003-fix-concurrent-directory-creation.all.patch")
+sha256sums=('34c44ba31397b471e7c36a0b07ff2e56c30a20a0a280caba0ad13fb0adbbc8e5'
+ 'fc23bd3c9e62a28cb1c020cebc83ca7532a5a7a21c2e4748b72d13ac7716a851')
+
+_srcdir="${_pkgname}-v${pkgver}"
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-pkgver() {
- cd "$srcdir/libxslt"
- git describe --tags | sed 's/^v//;s/-/+/g'
-}
-
prepare() {
- cd "$srcdir/libxslt"
- patch -p1 -i "${srcdir}/libxslt-1.1.26-w64.patch"
- patch -p1 -i "${srcdir}/libxslt.m4-libxslt-1.1.26.patch"
- patch -p1 -i "${srcdir}/0003-fix-concurrent-directory-creation.all.patch"
- NOCONFIGURE=1 ./autogen.sh
+ cd "$_srcdir"
+ patch -p1 -i "${srcdir}/0003-fix-concurrent-directory-creation.all.patch"
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "$srcdir/libxslt"
- unset LDFLAGS
+ cd "$_srcdir"
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
- ${_arch}-configure \
- --with-libxml-prefix=/usr/${_arch} \
- --without-python
+ ${_arch}-configure --without-python
make
popd
done
@@ -47,11 +35,13 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "$srcdir/libxslt/build-${_arch}"
+ cd "$srcdir/$_srcdir/build-${_arch}"
make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/${_arch}/share/doc"
+ rm -rf "$pkgdir/usr/${_arch}/share/man"
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}
diff --git a/libxslt-1.1.26-w64.patch b/libxslt-1.1.26-w64.patch
deleted file mode 100644
index ea63954a5f5d..000000000000
--- a/libxslt-1.1.26-w64.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur libxslt-1.1.26/configure.in libxslt-1.1.26/configure.in
---- libxslt-1.1.26/configure.in 2009-09-24 16:27:30.000000000 +0200
-+++ libxslt-1.1.26/configure.in 2009-11-11 17:51:06.000000000 +0100
-@@ -627,7 +627,7 @@
- WIN32_EXTRA_LDFLAGS="-no-undefined"
- ;;
- *-*-mingw*)
-- WIN32_EXTRA_LIBADD="-lwsock32"
-+ WIN32_EXTRA_LIBADD="-lws2_32 -lmswsock"
- WIN32_EXTRA_LDFLAGS="-no-undefined"
- AC_DEFINE([_WINSOCKAPI_],1,[Using the Win32 Socket implementation])
- AC_DEFINE([snprintf],[_snprintf],[Win32 Std C name mangling work-around])
-Only in libxslt-1.1.26: configure.in.orig
diff --git a/libxslt.m4-libxslt-1.1.26.patch b/libxslt.m4-libxslt-1.1.26.patch
deleted file mode 100644
index d6aaae4e9df0..000000000000
--- a/libxslt.m4-libxslt-1.1.26.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -ur libxslt-1.1.26.orig/libxslt.m4 libxslt-1.1.26/libxslt.m4
---- libxslt-1.1.26.orig/libxslt.m4 2009-05-12 09:29:34.000000000 +0300
-+++ libxslt-1.1.26/libxslt.m4 2009-10-07 17:03:04.000000000 +0300
-@@ -52,8 +52,10 @@
- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
- if test "x$enable_xslttest" = "xyes" ; then
- ac_save_CFLAGS="$CFLAGS"
-+ ac_save_CXXFLAGS="$CXXFLAGS"
- ac_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $XSLT_CFLAGS"
-+ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
- LIBS="$XSLT_LIBS $LIBS"
- dnl
- dnl Now check if the installed libxslt is sufficiently new.
-@@ -138,6 +140,7 @@
- }
- ],, no_xslt=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
- CFLAGS="$ac_save_CFLAGS"
-+ CXXFLAGS="$ac_save_CXXFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi
-@@ -158,6 +161,7 @@
- else
- echo "*** Could not run libxslt test program, checking why..."
- CFLAGS="$CFLAGS $XSLT_CFLAGS"
-+ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
- LIBS="$LIBS $XSLT_LIBS"
- AC_TRY_LINK([
- #include <libxslt/xslt.h>
-@@ -177,6 +181,7 @@
- echo "*** or that you have moved LIBXSLT since it was installed. In the latter case, you"
- echo "*** may want to edit the xslt-config script: $XSLT_CONFIG" ])
- CFLAGS="$ac_save_CFLAGS"
-+ CXXFLAGS="$ac_save_CXXFLAGS"
- LIBS="$ac_save_LIBS"
- fi
- fi