summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSchala2016-06-21 00:54:39 -0700
committerSchala2016-06-21 00:54:39 -0700
commitda07d69283c030682963d8ed77ac0e4e7c898f39 (patch)
tree6bde1d392b73d98440afa01a44c035e45a0cf711
parentaf88beca174be3c33b527ff3628ec103476e2856 (diff)
downloadaur-da07d69283c030682963d8ed77ac0e4e7c898f39.tar.gz
1.1.29
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--0003-fix-concurrent-directory-creation.all.patch20
-rw-r--r--0005-fix-freelocales-export.all.patch18
-rw-r--r--CVE-2015-7995.patch29
-rw-r--r--PKGBUILD21
-rw-r--r--libxslt.m4-libxslt-1.1.26.patch38
-rw-r--r--mingw32-libxslt-use-correct-mkdir.patch14
8 files changed, 77 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db261d15a8c4..4762080d14f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jan 13 23:33:13 UTC 2016
+# Tue Jun 21 07:54:10 UTC 2016
pkgbase = mingw-w64-libxslt
pkgdesc = XML stylesheet transformation library (mingw-w64)
- pkgver = 1.1.28
- pkgrel = 7
+ pkgver = 1.1.29
+ pkgrel = 1
url = http://xmlsoft.org/XSLT
arch = any
license = custom
@@ -14,18 +14,16 @@ pkgbase = mingw-w64-libxslt
options = !strip
options = staticlibs
options = !buildflags
- source = http://xmlsoft.org/sources/libxslt-1.1.28.tar.gz
- source = mingw32-libxslt-use-correct-mkdir.patch
- source = 0005-fix-freelocales-export.all.patch
+ source = http://xmlsoft.org/sources/libxslt-1.1.29.tar.gz
source = libxslt-1.1.26-w64.patch
source = libxslt-1.1.28-win32-shared.patch
- source = CVE-2015-7995.patch
- md5sums = 9667bf6f9310b957254fdcf6596600b7
- md5sums = d9a2f525f8f703d8e2000000dcaa943e
- md5sums = ee6e3e375b8ea2f42c7039e13f14f0c8
+ source = libxslt.m4-libxslt-1.1.26.patch
+ source = 0003-fix-concurrent-directory-creation.all.patch
+ md5sums = a129d3c44c022de3b9dcf6d6f288d72e
md5sums = b994c0d9df0f644e219cf63561ee0d4e
md5sums = 19646f155b518b40cb63e41270215964
- md5sums = b97b695cbe4171f8cb10df41f652aba5
+ md5sums = 61b520bbd42006c16bbfc85bc5342b96
+ md5sums = 6da8eb266e6be4f843cf63bd74c6388b
pkgname = mingw-w64-libxslt
diff --git a/.gitignore b/.gitignore
index 25cca9a92b37..5b06d8419137 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.gz
+*.tar
*.xz
diff --git a/0003-fix-concurrent-directory-creation.all.patch b/0003-fix-concurrent-directory-creation.all.patch
new file mode 100644
index 000000000000..68a6a3dfd483
--- /dev/null
+++ b/0003-fix-concurrent-directory-creation.all.patch
@@ -0,0 +1,20 @@
+--- libxslt-1.1.29/libxslt/security.c.orig 2013-04-01 02:31:05 +0400
++++ libxslt-1.1.29/libxslt/security.c 2013-04-01 02:32:21 +0400
+@@ -342,8 +342,16 @@
+ }
+ }
+ ret = xsltCheckWritePath(sec, ctxt, directory);
+- if (ret == 1)
++ if (ret == 1) {
+ ret = mkdir(directory, 0755);
++ if (ret == -1 && errno == EEXIST) {
++ struct stat buf;
++ ret = stat(directory, &buf);
++ if (ret == 0) {
++ ret = S_ISDIR(buf.st_mode) ? 0 : -1;
++ }
++ }
++ }
+ }
+ xmlFree(directory);
+ if (ret < 0)
diff --git a/0005-fix-freelocales-export.all.patch b/0005-fix-freelocales-export.all.patch
deleted file mode 100644
index bea1d4d3691c..000000000000
--- a/0005-fix-freelocales-export.all.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- libxslt-1.1.27/libxslt/xsltlocale.h.orig 2012-09-26 17:54:17 +0400
-+++ libxslt-1.1.27/libxslt/xsltlocale.h 2012-09-26 18:08:49 +0400
-@@ -12,6 +12,7 @@
- #define __XML_XSLTLOCALE_H__
-
- #include <libxml/xmlstring.h>
-+#include "xsltexports.h"
-
- #ifdef XSLT_LOCALE_XLOCALE
-
-@@ -53,6 +53,6 @@
- void xsltFreeLocale(xsltLocale locale);
- xsltLocaleChar *xsltStrxfrm(xsltLocale locale, const xmlChar *string);
- int xsltLocaleStrcmp(xsltLocale locale, const xsltLocaleChar *str1, const xsltLocaleChar *str2);
--void xsltFreeLocales(void);
-+XSLTPUBFUN void XSLTCALL xsltFreeLocales (void);
-
- #endif /* __XML_XSLTLOCALE_H__ */
diff --git a/CVE-2015-7995.patch b/CVE-2015-7995.patch
deleted file mode 100644
index fbcd7ea9055c..000000000000
--- a/CVE-2015-7995.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 7ca19df892ca22d9314e95d59ce2abdeff46b617 Mon Sep 17 00:00:00 2001
-From: Daniel Veillard <veillard@redhat.com>
-Date: Thu, 29 Oct 2015 19:33:23 +0800
-Subject: Fix for type confusion in preprocessing attributes
-
-CVE-2015-7995 http://www.openwall.com/lists/oss-security/2015/10/27/10
-We need to check that the parent node is an element before dereferencing
-its namespace
----
- libxslt/preproc.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/libxslt/preproc.c b/libxslt/preproc.c
-index 0eb80a0..7f69325 100644
---- a/libxslt/preproc.c
-+++ b/libxslt/preproc.c
-@@ -2249,7 +2249,8 @@ xsltStylePreCompute(xsltStylesheetPtr style, xmlNodePtr inst) {
- } else if (IS_XSLT_NAME(inst, "attribute")) {
- xmlNodePtr parent = inst->parent;
-
-- if ((parent == NULL) || (parent->ns == NULL) ||
-+ if ((parent == NULL) ||
-+ (parent->type != XML_ELEMENT_NODE) || (parent->ns == NULL) ||
- ((parent->ns != inst->ns) &&
- (!xmlStrEqual(parent->ns->href, inst->ns->href))) ||
- (!xmlStrEqual(parent->name, BAD_CAST "attribute-set"))) {
---
-cgit v0.11.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 0b67fa5b8f47..37f8d607dde3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-libxslt
-pkgver=1.1.28
-pkgrel=7
+pkgver=1.1.29
+pkgrel=1
pkgdesc="XML stylesheet transformation library (mingw-w64)"
arch=(any)
url="http://xmlsoft.org/XSLT"
@@ -9,26 +9,23 @@ depends=(mingw-w64-crt mingw-w64-libxml2 mingw-w64-libgcrypt)
makedepends=(mingw-w64-configure)
options=(!strip staticlibs !buildflags)
source=("http://xmlsoft.org/sources/libxslt-${pkgver}.tar.gz"
-"mingw32-libxslt-use-correct-mkdir.patch"
-"0005-fix-freelocales-export.all.patch"
"libxslt-1.1.26-w64.patch"
"libxslt-1.1.28-win32-shared.patch"
-"CVE-2015-7995.patch")
-md5sums=('9667bf6f9310b957254fdcf6596600b7'
- 'd9a2f525f8f703d8e2000000dcaa943e'
- 'ee6e3e375b8ea2f42c7039e13f14f0c8'
+"libxslt.m4-libxslt-1.1.26.patch"
+"0003-fix-concurrent-directory-creation.all.patch")
+md5sums=('a129d3c44c022de3b9dcf6d6f288d72e'
'b994c0d9df0f644e219cf63561ee0d4e'
'19646f155b518b40cb63e41270215964'
- 'b97b695cbe4171f8cb10df41f652aba5')
+ '61b520bbd42006c16bbfc85bc5342b96'
+ '6da8eb266e6be4f843cf63bd74c6388b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd libxslt-${pkgver}
patch -p1 -i "${srcdir}/libxslt-1.1.26-w64.patch"
patch -p1 -i "${srcdir}/libxslt-1.1.28-win32-shared.patch"
- patch -p0 -i "${srcdir}/mingw32-libxslt-use-correct-mkdir.patch"
- patch -p1 -i "${srcdir}/0005-fix-freelocales-export.all.patch"
- patch -Np1 -i ../CVE-2015-7995.patch
+ patch -p1 -i "${srcdir}/libxslt.m4-libxslt-1.1.26.patch"
+ patch -p1 -i "${srcdir}/0003-fix-concurrent-directory-creation.all.patch"
autoreconf -fi
}
diff --git a/libxslt.m4-libxslt-1.1.26.patch b/libxslt.m4-libxslt-1.1.26.patch
new file mode 100644
index 000000000000..d6aaae4e9df0
--- /dev/null
+++ b/libxslt.m4-libxslt-1.1.26.patch
@@ -0,0 +1,38 @@
+diff -ur libxslt-1.1.26.orig/libxslt.m4 libxslt-1.1.26/libxslt.m4
+--- libxslt-1.1.26.orig/libxslt.m4 2009-05-12 09:29:34.000000000 +0300
++++ libxslt-1.1.26/libxslt.m4 2009-10-07 17:03:04.000000000 +0300
+@@ -52,8 +52,10 @@
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_xslttest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
++ ac_save_CXXFLAGS="$CXXFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$XSLT_LIBS $LIBS"
+ dnl
+ dnl Now check if the installed libxslt is sufficiently new.
+@@ -138,6 +140,7 @@
+ }
+ ],, no_xslt=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+@@ -158,6 +161,7 @@
+ else
+ echo "*** Could not run libxslt test program, checking why..."
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$LIBS $XSLT_LIBS"
+ AC_TRY_LINK([
+ #include <libxslt/xslt.h>
+@@ -177,6 +181,7 @@
+ echo "*** or that you have moved LIBXSLT since it was installed. In the latter case, you"
+ echo "*** may want to edit the xslt-config script: $XSLT_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
diff --git a/mingw32-libxslt-use-correct-mkdir.patch b/mingw32-libxslt-use-correct-mkdir.patch
deleted file mode 100644
index 6f58d374671c..000000000000
--- a/mingw32-libxslt-use-correct-mkdir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- libxslt/security.c.orig 2010-10-13 15:42:00.790273503 +0200
-+++ libxslt/security.c 2010-10-13 15:42:34.425556664 +0200
-@@ -343,7 +343,11 @@
- }
- ret = xsltCheckWritePath(sec, ctxt, directory);
- if (ret == 1)
-+#ifdef WIN32
-+ ret = mkdir(directory);
-+#else
- ret = mkdir(directory, 0755);
-+#endif
- }
- xmlFree(directory);
- if (ret < 0)